Release Notes

From Q
Jump to: navigation, search

The changes in each new version of Q are listed below.

Contents


Q5.2

5.2.5.0

2017-11-13
  • Fixed bug where rounding errors can result in the treatment of the median, percentiles and effective sample size to be inconsistent. Based on our sensitivity analysis we have confirmed that this only leads to changes in results in situations where the change is immaterial.
  • Other bug fixes

5.2.4.0

2017-10-18
  • Improve import of MDD data files.

5.2.3.0

2017-09-28
  • Improve import of MDD data files.
  • Other bug fixes

5.2.2.0

2017-09-08
  • Date variables can display time in charts and tables. Date variables can be aggregated using hours, minutes, seconds or milliseconds.
  • Previously when a variable from a Pick Any question only had Missing Data and 1 as values, 1 would not be counted, resulting in 0% shown in the table. 1 is now counted and shown as 100% in the table.
  • Q requires .Net 4.5.2 to be fully operational.
  • It is now possible to hide tables, charts, R outputs and complete folders from export using Hide from the context menu.
  • R Outputs returning scalar values and strings are now exported as text to PowerPoint and Word.
  • Fixed bug where multiple comparisons correction in Table Options was ignored in Driver Analysis.
  • Fixed question naming issues when importing MDD data files.
  • Improved looped question detection when importing MDD data files.
  • Fixed bug where an incorrect log-likelihood was reported when weights were applied in Segments > Latent Class Analysis.
  • Other bug fixes.

Q5.1

5.1.2.0

2017-02-10

5.1.1.0

2016-11-18
  • Data tables can now be manually entered or pasted in Q via Create > Tables > Enter Data and Paste Data, as well as in Standard R items that accept tabular inputs.
  • Other improvements and bug fixes.

Q5.0

5.0.3.0

2016-09-27
  • Classifier - Random Forest
  • Analysis of Variance - One-Way ANOVA
  • Analysis of Variance - One-Way MANOVA
  • Fixed bug with Spearman’s Correlation where Spearman ranks were being calculated without omitting the cases with missing values in any of the two input variables. The impact of this bug should be minimal and proportional to the amount of missing values in the data set. We have observed that the bug typically resulted in a difference in the reported Spearman correlation at the 4th decimal place compared to the correct value. As a result, is unlikely that this bug would have affected Spearman correlation significance test results and any inferences made from them.
  • Improved Qualtrics and Survey Gizmo data file detection
  • Fixed a bug where by the word "mean" was appearing in the place of "proportion" in some test outputs.
  • Other bug fixes and improvements

5.0.2.0

2016-09-08
  • Bug fixes

5.0.1.0

2016-08-30

Q4.11

4.11.15.0

TBA

4.11.14.0

2016-06-29
  • Bug fixes

4.11.13.0

2016-06-10
  • Bug fixes

4.11.12.0

2016-06-07
  • Bug fixes

4.11.11.0

2016-06-01

4.11.10.0

2016-02-19
  • Bug fixes

4.11.9.0

2016-02-02
  • Bug fixes

4.11.8.0

2015-12-08
  • Bug fixes

4.11.6.0

2015-10-28
  • Bug fixes

4.11.5.0

2015-09-07
  • Bug fixes.

4.11.4.0

2015-08-14
  • Bug fixes.

4.11.3.0

2015-07-27
  • Bug fixes.

4.11.2.0

2015-07-02
  • Export to Excel (fast) now works without Office installed.
  • New Table Context Menu items allow you to modify questions without leaving the table, including renaming the Question and changing its Question Type.

4.11.1.0

2015-06-15
  • Banners can be modified directly on tables by dragging and dropping column spans.
  • Individual banner points can be added directly on tables using new concise Logic formulas.
  • New Ranking plot visualizes changes in ranks as a series of colored ribbons.

Q4.10

4.10.6.0

2015-04-23
  • Bug fixes.

4.10.5.0

2015-03-27
  • Significance arrows and column comparison letters are now included in Excel spreadsheets and PowerPoint chart labels.
  • Bug fixes.

4.10.4.0

2015-02-24
  • Bug fixes.

4.10.3.0

2015-02-24
  • Bug fixes.

4.10.2.0

2015-02-16

Q4.9

4.9.7.0

2015-01-30
  • Bug fixes.

4.9.6.0

2015-01-14
  • Bug fixes.

4.9.5.0

2014-12-11
  • Bug fixes.

4.9.4.0

2014-10-29
  • Bug fixes.

4.9.3.0

2014-10-01
  • Bug fixes.

4.9.2.0

2014-09-17
  • Bug fixes.

4.9.1.0

2014-09-08
  • Q is faster when working with large data files (100,000+ cases).
  • New Find and Replace feature allows you to search everything in your project: tables, variables, value attributes, raw data and more.
  • Improved importing of CSV and Excel data files.

Q4.8

4.8.9.0

2014-08-20
  • Bug fixes.

4.8.8.0

2014-06-30

4.8.6.0

2014-06-13
  • The tables created by Automate > Browse Online Library > Driver (Importance) Analysis can now be crosstabbed against Pick One, Pick Any and Date questions.
  • TURF is now available from Automate > Browse Online Library, allowing you to select products and maximum portfolio size.

4.8.5.0

2014-06-12
  • Bug fixes.

4.8.4.0

2014-06-04
  • Bug fixes.

4.8.3.0

2014-05-30
  • Rules let you automatically highlight important cells and reformat tables.
  • Significance of table cells is now calculated by Q prior to Rules. This allows Rules to format tables based on Corrected p, and to modify arrows and font colors.
  • Driver (Importance) Analysis is available from Automate > Browse Online Library.
  • Tables of Pick Any - Compact questions now automatically remove respondents who were not asked the question.

4.8.2.0

2014-03-26
  • Bug fixes.

4.8.1.0

2014-03-19
  • Bug fixes.

Q4.7

4.7.5.0

2014-04-11
  • Bug fixes.

4.7.4.0

2014-03-20
  • Bug fixes.

4.7.3.0

2014-02-20
  • Bug fixes.

4.7.2.0

2014-02-13
  • Project Templates let you set default statistical assumptions, table styles, colors, etc. for new projects.
  • Bug fixes.

4.7.1.0

2014-01-23
  • The QScript Online Library provides pre-written QScripts to perform common tasks. It is available in the Tools menu, QScripts, Online Library.
  • Use Excel spreadsheets as raw data.
  • Now much easier to control whether/how significance is shown for any table/plot. Look for the new "Show significance" toolbar.
  • Plots can now show column comparisons.
  • Plots can show significance arrows without also needing to show labels. Most plots now show significance by default.

Q4.6

4.6.6.0

2013-12-05
  • Bug fixes.

4.6.5.0

2013-11-08
  • Bug fixes.

4.6.4.0

2013-10-25
  • Bug fixes.

4.6.3.0

2013-09-27
  • Tables with no data will no longer stop Microsoft Office exports mid-stream.
  • During text coding, codes may now have the same name so long as they do not have the same parent code.
  • Fixed inconsistent spacing between letters on plots exported as pictures to PowerPoint or Word.
  • Axis labels on plots can be turned off.
  • Bug fixes.

4.6.2.0

2013-09-10
  • Text questions can now be crosstabbed against Pick One, Pick Any, Pick Any - Compact or Date questions.
  • Excel table exports can now be formatted using Excel's table styles, within Q.
  • Bug fixes.

Q4.5

4.5.5.0

2013-09-06
  • Bug fixes.

4.5.4.0

2013-08-06
  • Q now works with R3.0.1.
  • Bug fixes.

4.5.3.0

2013-06-25
  • Bug fixes.

4.5.2.0

2013-06-05
  • Bug fixes.

4.5.1.0

2013-05-16
  • You can specify the gaps between tables when exporting all tables to a single Excel worksheet.

Q4.4

4.4.4.0

2013-05-10
  • Bug fixes.

4.4.3.0

2013-04-12
  • Bug fixes.

4.4.2.0

2013-03-13
  • Bug fixes.

4.4.1.0

2013-02-21
  • Help | Interpret This Table prepares a summary of some of the salient aspects of a table.
  • Basic Tables has a new checkbox that allows you to add all crosstabs into a single group (instead of adding one group for each Key question's crosstabs).

4.4.0.0

2013-01-21
  • Export to native PowerPoint tables. These look much better than the old tables, and will work with PowerPoint table styles.

Q4.3

4.3.21.0

2012-12-21
  • Bug fixes.

4.3.20.0

2012-11-27
  • Bug fixes.

4.3.19.0

2012-11-21
  • Bug fixes.

4.3.18.0

2012-11-19
  • Time series charts allow you to select the statistic to be plotted.
  • Significance tests on Number questions now test against an expected value of 0.0 (previously no result was shown).
  • Choice of significance tests for grid questions (e.g., Nonparametric, z-tests, Quantum and Survey reporter).

4.3.17.0

2012-10-10
  • The multiple comparison correction for Column Comparisons can now be applied to the whole table, or, within each row and span. (Previously it was only applied within each row and span.)
  • Symbols used in Column Comparisons (e.g., upper case for significance levels than 0.001 and lower case for between 0.001 and 0.05 are now computed using the Corrected p. Previously they were computed using p. Note that this does not change which column comparisons are marked as significant, it only changes the letters used. Also note that this change only affects users on the beta, as the different column letters are not available in older versions of Q.
  • Improved warnings when Experiment questions have been setup incorrectly.
  • Modified list of Multivariate Tests (no change in the tests, but modified names of the tests).
  • The Independent Complex Samples t-Test - Comparing Two Means is now the default test employed with weighted data (previously a version assuming equal variance was applied in situations with small sample sizes).
  • The Independent Samples t-Test - Comparing Two Coefficients for an Experiment and Ranking questions now uses the effective sample size when computing the degrees of freedom (previously it took into account the effective number of observations).

4.3.16.0

2012-09-11

4.3.15.0

2012-08-28
  • Fixed problem with three-dimensional crosstabs with Date questions in the brown dropdown.
  • Fixed problem with Column Comparisons in three-dimensional crosstabs.

4.3.14.0

2012-08-24

Please note: a number of the new features described here were available in some earlier 4.3 releases.

4.3.12.0

2012-06-26
  • Pie charts.
  • JavaScript variables now have the ability to reference variables in other data files.

4.3.9.0

2012-03-27
  • When (for example) you restrict a weekly Date question to end on a Wednesday then calculated weeks will go from Thursday to Wednesday. Similarly for months and years. Previously Q moved periods to match natural boundaries (Sunday, end of month, etc) in this case.

4.3.8.0

2012-03-26
  • Q can read SPSS Data Collection Data Files (.mdd + .ddf).
  • New and improved JavaScript variable editor.
  • Edit | Table JavaScript - allows you to script the output of a table or plot, which can generate heatmaps, custom significance highlighting, and more.

4.3.7.0

2012-03-12
  • New weighting facility - enter targets as percentages, handles new waves of trackers, automatic rim weighting (combines multiple weight targets), enter targets that vary by month.

4.3.5.0

2012-02-24
  • Fetching raw data from SQL databases.

4.3.1.0

2012-02-06
  • Find relationships between variables: right click and choose Trace Dependencies

4.3.0.0

2012-01-27
  • New type of output: Text. Allows you to enter formatted text and bullet lists to be displayed in PowerPoint slides or an online dashboard.
  • Significance test highlighting and column comparisons are now customizable: arrow size, text color, text size and column names can be customized at specific p-value cutoffs.
  • QScripts are new Office-like macros for Q, allowing you to modify variables and questions and customize your tables and plots using JavaScript.

Q4.2

4.2.20.0

4.2.19.0

4.2.14.0

  • Improved varimax rotation algorithm in Principal Components Analysis.
  • Fixed bug in significance testing for trend plots.
  • Changed treatment of dates in Complicated Binary Variables. Missing values are now always returned as false. Previously treated as less than all other dates.

4.2.7.0

  • Q can update the data in exports to PowerPoint and Excel, leaving your slides and changes intact.

4.2.6.0

  • Many new plot types.
  • Multiple data files can be loaded into a Q project.
  • Time series can show two series from different data files (e.g. advertising spend and customer satisfaction).
  • Upload a Q project to an online dashboard via File | Share as Dashboard. (Dashboards purchased separately.)
  • The names of statistics can now be customised (e.g. 'NPS' instead of 'Average'); see the Output Text tab in either Project Options or Table Options.
  • Statistical assumptions (including multiple comparisons method of significance testing) can now be set per table.
  • Sorting by statistics now works on multiple tables at once.
  • Office 2007 and later: titles are now included in exported charts. You can turn them off using templates.
  • Improved support for dates and times in Excel-style and JavaScript formulas.
  • Ability to copy selected cells from Q to Excel.
  • Custom text may be entered into table footers.
  • Coded questions now show spans and sub-NETs for parent codes in the codeframe.
  • Text variables which are converted to Categorical variables by Q will now update seamlessly with new text responses.

Q4.1

4.1.8.0

  • Shift+F3 changes case of selected labels similar to Word.

4.1.4.0

  • New question type Pick Any - Compact.
  • New Tables Tab feature - View | Hide Empty Rows/Columns.
  • May edit time series analysis (smoothing) options in Date crosstabs.
  • Ability to check out transferable licenses from Q.
  • List of deleted cases that can be individually restored via the Data Tab.
  • Trees can now handle all categorical and numeric variables.
  • Improvements in planned significance tests.
  • Pairwise comparisons between different columns in a table.
  • Improvements in the way that sample size is presented.
  • Moving averages on statistics in tables.

4.1.3.0

  • Q runs in 64-bit mode on 64-bit editions of Windows; can handle bigger tables, bigger data files.
  • Analysis outputs improved - may now copy and paste output tables to Excel.
  • Merge Pick One and Pick Any questions by right-clicking in the Variables tab and selecting Insert Ready-Made Formula(s) | Merge Questions.
  • You may Undelete categories from a table while still retaining any merging or netting already done.
  • The method for computing the number of degrees of freedom in ranking questions has been modified; please e-mail Q Support for more information.
  • Automatic tests of significance have been improved for Date questions; please e-mail Q Support for more information.

4.1.2.0

  • You can drag variables, questions and tables between open Q projects. Not all types of variables and tables are supported.

4.1.1.0

  • JavaScript variables are faster. (This includes banner questions.)
  • Q can export to XtabML, used by E-Tabs.
  • Statistical tests for the whole table may be exported to Excel (click File | Export to Office, then Advanced button).
  • The Excel-style formula functions SEARCH, FIND and REPLACE have been added.
  • New hotkey to lock and unlock tables (Ctrl + L).
  • Coding: text responses can be sorted by number of responses.
  • Exporting raw variables to Excel is much faster.

Q4.0

4.0.22.0

  • Multiple correspondence analysis available by clicking Create | Map.

4.0.19.0

  • Q can now use data from Triple-S (.sss) files.

4.0.18.0

  • The new Q Online Training system is now available from the Help menu.

4.0.17.0

  • Ability to automatically update license when renewal invoices are paid.
  • No requirement to be Administrator when activating or deactivating license.
  • Modified significance tests for Pick Any - Grid and Number - Grid questions (previously known as Two Dimensional questions); they now produce significance tests of NET and SUM.

4.0.16.0

  • A new software licence agreement which contains a clause that protects both parties in regards to confidential information, so that you can send bug reports to us containing your client's data, and it will be kept in confidence.

4.0.0.0

  • New question types: Experiment, Ranking, Date.
  • Tools | Save Data as SPSS .sav File
  • Tools | Convert .sps File to .sav
  • Tools | Merge Data Files | Add New Cases
  • Tools | Merge Data Files | Add New Variables
  • Toggle multiple table statistics by holding down Ctrl.
  • Segmentation (or classification) trees, in the Create menu.
  • Time series plots, in the Create menu.
  • Use <filter> and <weight> in table or group names, and they will be replaced with the actual filter and weight labels upon exporting.
  • Spans included in Excel exports of tables.
  • Copy and Paste Question(s) in the Variables and Questions tab.

Q3

3.3.8.0

  • An important bug fix: in some tables, the 'Sample scaling constant' from 'Analysis | Statistical Assumptions...' was ignored.

3.3.0.0

  • Shortcut (Ctrl + I) to select all variables in a question in the Variables and Questions tab.

3.2.6.0

  • The way chart templates work has changed. Go to User Options and reconfigure them.
  • Q works with Office 2007 chart templates.
  • Chart templates can be set for individual tables.
  • Effective sample size now computed for each cell in a table. Effective sample size shown at the bottom of the page is the largest of these.

3.2.0.0

  • Medians, quartiles and trimmed averages.

3.1.1.0

  • Support for Money-type variables and symbols.
  • Extra missing values identified in SPSS files are now understood.
  • Improved automatic setup of two-dimensional questions.
  • Turn statistics on or off for multiple tables at once in the Report tree.
  • Choose if and where SUMMARY/frequency tables get output from Basic Tables.
  • New Variables and Questions Tab operation: Combine (Binary) Variables.
  • Ability to find variables in Data Tab (shortcut: F5 key).

3.0.0.0

  • A Data tab to view, edit and sort raw data, and to create variables using Excel formulas (e.g., =Q2+Q7).
  • Multiple filters on a single table.
  • Table styles, which control the appearance of tables on screen and when exported.
  • Advanced regression, including an expert system to select the appropriate test.
  • Latent class analysis, which forms segments using both numeric and categorical data.
  • Rim weighting.
  • Tidy categories in a table by sorting categories and Search/Replace...
  • Q projects can be read into R.
  • Convert an unstacked SPSS data file into a stacked SPSS data file.
  • New categories can be added to a banner question.
  • Spans can be used to show different groups of categories in a question (e.g., within a banner question).
  • Additional variables can be pasted from Excel.

Q2

2.3.3.0

  • Percentages in Q are exported to Excel as formatted percentages, when you display % signs in a table in Q. Please check any automated workbooks that use these values.

2.3.1.0

  • Better handling of large data files.

2.0.2.0

  • Row and column statistics.
  • Exporting to Microsoft Word.
  • Improved report print-outs/PDFs, with scaled bar graphs and cell colouring.
  • Separate control of decimal places for each data series.
  • Recoding ranges of variable values using rules.
  • Cover pages on printed/PDF reports.
  • Table of contents in printed/PDF reports and optionally in Excel exports.
  • Customisable PowerPoint exports.

Q1

1.5.1.0

  • Improved Cluster Analysis algorithm.

1.5.0.0

  • Basic Tables feature, available from 'Advanced | Basic Tables...'

1.4.0.0

  • Ability to import/export codes in your coded variables (via the right-click context menu in the code editor).
  • Ability to 'tag' questions so they may be used as filters, weights, or be hidden from the blue and brown dropdowns.

1.3.0.0

  • Ability to view simple statistics of all variables via View | Show Statistics.
  • Ability to add Comments to variables in the Variables and Questions tab (via right-click menu).
  • Coding module, now available to all licensed users.
  • Moon plot option for Correspondence Analysis.
  • Drag and dropping of variables in the Variables and Questions tab.

1.1.0.0

  • Ability to export raw data using 'File | Export Selected Variables to Excel...'

1.0.2736.33301

  • Customisation of print/PDF report fonts.
  • Ability to export project and data file as a package to clients using 'File | Send Package'.

1.0.2712.17650

  • Ability to control the layout of two-dimensional questions.
  • Ability to rename variable labels using search and replace.

1.0.2693.19516

  • Ability to provide templates for exporting charts to Microsoft Office.

1.0.2677.29899

  • Ability to customize default Office chart types (available through 'Edit | Default Export Options...').
  • Enhancements to Office exporting.

1.0.2657.20305

  • Enhanced Office chart appearance.
  • Ability to 'link' variables (right-click on a variable and select 'Construct New Variable(s) | Linked...').
  • Faster start-up time.
  • Web version check, available through 'Help | Check for New Version'.
  • Locking of Q project files during editing - prevent other people editing your project at the same time.
  • Ability to tell Q what to do with new variables from a data file.

1.0.2603.22342

  • Compatibility with Windows Vista.

1.0.2586.20118

  • License information is now shown in the About dialog.

1.0.2585.29173

  • Currently selected filter is now included in new filter when you press the "Create filter variable" toolbar button.
  • New icons for menus.

1.0.2573.27532

  • New icons for all types of variables and questions.

1.0.2545.21451

  • New Smart Tables feature, available from the Advanced menu.
  • Type-ahead search boxes - added to the Variables and Questions list, as well as the Binary and Computed variable constructors.
  • Improved appearance of toolbars.

1.0.2532.29985

  • Added Computed Text Variables, so you can combine multiple text variables into one by joining together their responses (see Help for an example).

1.0.2526.17385

  • Added ability to create filters from selected table cells (click on the filter toolbar button).
  • Added ability to import SPSS for Mac files.

1.0.2508.20679

  • "Create Banner Question" added; available from the Advanced menu.

1.0.2490.20515

  • Improved handling of changes to data files.
  • Online help added.

1.0.2477.32121

  • Updated manuals, tutorials and reference guides.
  • Improved validation when constructing variables.