Exporting to PowerPoint

From Q
Jump to: navigation, search
Related Videos

All parts of Working With PowerPoint (Video)

Q can automatically export charts, tables and text to PowerPoint and update the PowerPoint presentation to reflect updates of data in Q.

The underlying programming for how this is done is changing with the introduction of Q version 5.11. You can check the version of Q you have installed by going to the Help menu and selecting About. Contact Support for further information.


Exporting to PowerPoint Q version 5.11 or later

To export a selected output from Q to PowerPoint you can either click on the PowerPoint export icon PPT Icon.png, or by right-clicking on the Q output > | Export to Office > Export to PowerPoint.

A Table Options dialog box appears, where you can select the desired Format and Chart type. Outputs can be exported as Images, or editable Tables or Charts.

Export editable charts to PowerPoint

In the Table options menu, set the Format to To PowerPoint as Excel Chart and select the desired chart type from the Chart menu.

TableOptions.png

Update an existing PowerPoint document

Charts, tables and images exported from Q to a PowerPoint document are linked back to Q and can be updated. Note: this feature is not available when exporting format is set to To PowerPoint as Microsoft Graph.

This feature is particularly useful for updating reports for tracking studies. However, it has numerous other uses such as updating a specific output or report after applying a different filter (e.g. country), adding a cross-break, merging answer codes or adding a net, to name just a few.

To update a chart exported from Q click on PowerPoint Export fast icon PPTFastIcon.png or by right-clicking on the output > Export to Office > PowerPointFastUpate.

Select the file you wish to update. Q will create a new file, the content of which will be updated to reflect any changes done in Q. Q will save the file in the same folder alongside the original file, adding a consecutive number to the name (e.g. Export(1).pptx).

Updating is based on GUIDs

Every object that can be updated from Q has a GUID (Globally Unique Identifier code) assinged to it. To see the GUID right-click on the output and select Show GUID for this Item.


ShowGUIDItem 1.png GUID.png

GUIDs are recorded in the PowerPoint Alt Text field

In order for Q to update an object in PowerPoint, it is necessary to record the GUID in the Alt Text field in PowerPoint. This field is accessed in PowerPoint by right-clicking on the object (e.g., a chart), and selecting Edit Alt Text.....

AltText1.png

Connecting PowerPoint charts to Q

To connect a chart created in PowerPoint to an output created in Q select the output in Q > right click > Show GUID for this Item. You can select the GUID by using your mouse and clicking and dragging over it. It can be copied by right-clicking and selecting Copy. In PowerPoint right-click on the object > Edit Alt Text.... > CTRL+V (paste). The object in PowerPoint is now connected with Q and can be updated.

In order for PowerPoints outputs such as charts to update correctly, it's important to ensure that the layout of the data tables in Displayr and in the PowerPoint chart match – that is that the rows and columns of tables are positioned in the same way. To check the required layout, open your PowerPoint document > select the chart > right-click > Edit data. If the layout of the table doesn't match go back to Q, select the table, right-click on either row or column heading and select Swap rows and columns.

TableLayout.png

Exporting to PowerPoint - Q up until and including version 5.10

Charts

Q can either create standard PowerPoint charts at the time of export, or, export its own internal Charts.

PowerPoint Charts Q Charts
Data can be edited and viewed Can display significance tests
More extensive formatting options Developed specifically for market research

PowerPoint Charts

All of the standard Microsoft Office chart types can be exported and updated using Q, where 'standard' refers to the chart types that are selectable within PowerPoint, Excel and Word's Chart Type menus.

PowerPoint Chart Templates

Within Microsoft Office it is possible to automatically format charts using Chart Templates. These Chart Templates can be selected when exporting from Q (see Export to Office).

Export Chart Defaults

Office Chart Types and Office Chart Templates can be set as defaults for particular combinations of data using Edit > User Options > Export Chart Defaults.

Q's Charts

Q's Charts have been specifically designed for market research. In particular, they can display the results of tests of statistical significance.

Chart Templates

Any chart can be saved as a template using View > Save as Template. These templates can then be selected from the Show Data as menu (see Charts for more information).

General defaults

Default fonts, font sizes, font styles chart colors can be set at Edit > Project Options > Customize > Charts.

Tables

Image of Table

When exporting To PowerPoint as Image of Table, the general appearance of the table is controlled via Table Styles.

PowerPoint Table

When exporting To PowerPoint as PowerPoint Table, the general appearance of the table is controlled via settings in PowerPoint. The default table style comes from the Theme of the slideshow. You can change this default by right-clicking on your desired table style in the Table Style gallery of the DESIGN tab of the ribbon (you will need to manually change the first table).

Slide Layout

PowerPoint Templates

The major aspects of the layout of a slide are determined by the settings within PowerPoint files, which are, in turn, controlled by PowerPoint templates and PowerPoint's Master Slide settings.

PowerPoint Export Layout

Additional control over the appearance of exports in PowerPoint is available within Q via the PowerPoint Export Layout settings.

Shrink tables to fit one slide

By default, large tables are shrunk to fit into the available space. This can be turned off by selecting User Options > Display/Printing and de-selecting Shrink tables to fit in one slide (when exporting to PowerPoint) or in page margins (when exporting to Word).

Footers

Footers can be extensively customized. See Footers.

See also