Category:Charts

From Q
Jump to: navigation, search
Related Online Training modules
Switching from Tables to Plots
Plot Templates
Generally it is best to access online training from within Q by selecting Help : Online Training

Charts in Q are created by first creating a table and then turning this into a chart using the Show Data As drop-down menu: ShowDataAs.png.

These charts can be viewed in Q and can be exported to Word, PowerPoint and online Dashboards. Alternatively, create standard Microsoft Office charts in Excel, PowerPoint and Word using Export to Office.

Contents

Chart Types

Refer to Chart Types or click here for examples.

Standardizing the look and feel of charts

Select Edit > Project Options > Charts to set default colors and fonts. You can drag a chart from one project to another and it will remember its formatting (note that if you are using the default colors, the chart will apply the default colors of the new project; if you have merged categories together or created NETs, they will not be copied over).

Additionally, save a chart as a template by selecting View > Save as Template. These templates are then accessed from the Show Data as drop-down menu at the top of the screen.

Formatting

You can adjust the format of almost any part of the chart using the inspector on the right side of the screen. (For Q versions prior to 4.10 you must right click on items in the chart to see the available options.)

Bars versus columns Column charts can also be shown as bar charts. To swap the axes, select an axis in the inspector and tick Swap X and Y Axes.

Time Series: Smoothing series To apply smoothing, click on a line and look for TIME SERIES ANALYSIS in the inspector. See Time Series Analysis for a description of the options available there.

Chart size Adjust the chart area by clicking just to the right of the X axis to select the whole canvas. Then drag the lower-right circle to adjust the size. This size will be used when the chart is exported.

Legend By default the legend is shown as a single block. To show each series' label separately, right click on the key and select Break Legend into Multiple Labels

Formatting individual data points/bars To apply formatting to an individual bar or chart point, click once on the object to select its series, and then click on the particular point (or bar) to select that data point. Then use the inspector on the right, as usual.

Excluding data If you don't want to include some of your data (e.g. outlying scatter chart points) then use a filter, or hide those bits of the data reduction. If you try excluding data by adjusting the minimum and maximum of the axis then you risk unintentionally excluding the wrong points, if you get an updated data file.

Examples of formatting

  • To change the font of an axis, click on the axis and look for the expanded section in the inspector on the right of the screen.
  • To add the values to a chart for a series, click on the bars/lines of the series, look for DATA SERIES in the inspector, and check Label points.
  • To specify which date periods are to be included in the columns of a Column chart with trend, look for Period type under COLUMNS in the inspector.
  • To turn a column chart into a snake chart, create a Bar/column/line chart, click on any axis and then tick Swap X and Y Axes in the expanded section in the inspector. Then find DATA SERIES in the inspector and change Chart as from Column to Line.
  • When creating a Stacked column/bar chart, the position of the bars relative to the axis is determined by the Value (which is set by right clicking on the relevant categories in a table and selecting Values). Positive values appear above the axis, negative below and 0 values are shown in a separate table underneath the chart.

See also

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox