Data tab

From Q
Jump to: navigation, search
Related Online Training modules
Setting Filters in the Data Tab
Generally it is best to access online training from within Q by selecting Help > Online Training
Related Videos
Part 6 of Creating and Modifying Variables (Video)
 


The Data Tab lets you see the data being analyzed by Q. You select this tab by clicking the Data tab at the bottom left of the screen. Each row represents a case (typically, the data for an individual respondent in a survey). Each column represents a variable, with the Name of each variable shown at the top. The black lines above the variable names indicate how the variables are grouped into questions (these groupings can be changed in the Variables and Questions tab – see Set Question).

Case IDs

In order for Q to remember any data changes you make (for example, deleting cases and changing values), you first need to select a variable that contains a unique identifier for each respondent (e.g. a respondent number) from the Case IDs menu. Q will use this if your raw data file changes to ensure that the edits continue to apply to the appropriate case.

The option Use Case Number will use the position of the respondent in the file to keep track of the changes, and is NOT recommended if you intend to update your project with new data (using File > Import Updated Data File (current project)) because the order of the respondents in the file may change.

Q will only show variables in the Case IDs dropdown where they contain no duplicate values. If you have variables in your data file that contain duplicate values, and it is delete any cases that are duplicates. See How To Delete Duplicate Cases.

Buttons, Options and Fields

The following actions can be performed in the Data tab:

Sort the data: right click on a column header and select Sort to sort by that column. Alternatively, select Sort from the View menu to sort by more than one column.

Set a variable as a Filter/Weight: Right-click one of the variable names in the top row and select Available for Filtering or Available for Weighting.

Find Variable: Select Edit and Find Variable.

Search for values in a selected column: select the first cell in the column, type the value in the Find box and press Enter.

Highlight rows that match a filter variable: select a variable in the Filter drop-down at the bottom of the screen.

View using labels instead of numbers: tick the Show Labels checkbox in the top right.

Edit raw data: Select a cell and type a new value. Hover your mouse over any cell and a tool-tip will appear showing original values, labels, etc. You can change the data by clicking in a cell and typing a new value into the cell, or, by changing the data shown in the formula bar at the top of the screen. This is only a good approach when correcting errors – there are other better ways of recoding data recoding data (see Setting Up Data).

Use the formula bar: Edit long text variables or Excel-style formulas here.

Insert a new variable using an Excel-style formula: Create new formulas by right-clicking on a column header and using the Insert Variable(s) > Excel-style Formula.

Excel-style formulas can refer to variables by name and can use many normal Excel functions. For example:
=Q2+Q7
=1-AVERAGE(Q3,Q4,Q5)
=IF(Q1="M", 1, 2)

Press Enter when done or Escape to cancel.

View a cell's original value: Hover your mouse over any cell and a tool-tip will appear showing original values, labels, etc.

Delete cases: see How to Delete Cases (Observations). Prior to deleting data you first must set Case IDs (see above).

Paste in data for an entirely new variable: copy a column of data from Excel or any text editor and select Insert Variable(s) > Paste Data (e.g. From Excel). The number of entries you paste must match the number of cases in the raw data file. Where pasting multiple variables, variable names must be included in the first row. If importing large numbers of variables, or if there is a large number of respondents in the data file (> 10,000) it is better to instead use Merge Data Files and Updating Projects with New or Revised Data.

View several areas within the data simultaneously: split the screen by dragging one of the blocks positioned at the end of the scroll bars (i.e., the splitters).