How to Delete Cases (Observations)

From Q
Jump to: navigation, search
Related Online Training modules
Editing Data
Deleting Individual Observations
Deleting Multiple Observations
Generally it is best to access online training from within Q by selecting Help > Online Training

Cases are deleted on the Data tab. The Case ID must be set prior to deleting any cases (this is set using the drop-down at the top-left of the Data tab.

Contents

Deleting cases

Right click on the row(s) to be deleted and select Delete Row. With large projects that contain many variables this can take a surprisingly long amount of time as Q checks the consequences of the deletion on every variable and every table in a project, so it is often better to delete using a filter.

Deleting cases using a filter

Create a new Filter and, in the Data tab, apply the filter, then right-click and select Delete Rows Matching Filter (Green). If deleting large amounts of data, it is often advisable to delete them in the data file.

Deleting cases from the raw data

If you want to delete variables that are in a raw data file, you can do this by:

  1. Opening a new version of Q.
  2. Importing the data file, selecting No to any questions.
  3. Deleting the cases.
  4. Select Tools > Save Data as SPSS/CSV File and save it to somewhere appropriate.
  5. Select File > Data Sets > Update an import the modified data file.

See also

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox