How To Delete Duplicate Cases

From Q
Jump to: navigation, search
  1. Save your project.
  2. Select File > New Project.
  3. Select File > Data Sets > Add to Project > From File.
  4. In the Data Import Window:
    1. Select Use original data file structure.
    2. Untick Tidy Up Variable Labels and Strip HTML from Labels.
    3. Click OK.
  5. Set the Case IDs on the Data tab to Use Case Number.
  6. Delete any duplicate rows on the Data tab (right-click on the row numbers to see the options for deleting). If you are not sure which ones are duplicates, create a Pick One question from the id variable, create a SUMMARY table from it in the Outputs Tab, and sort the percentages from highest to lowest.
  7. Tools > Save Data as SPSS/CSV File and save the file somewhere.
  8. Open your existing project.
  9. File > Data Sets > Update.
  10. Select the data file created earlier, and press Open. Read any notifications and, if they seem OK, press Accept.
  11. Go to the Data tab.
  12. Right-click on any row number and select Revert Deleted Rows.
  13. Choose Check/uncheck all (at the bottom).
  14. Press Revert.
  15. Select the variable you wish to use for Case IDs.
Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox