Multiple Data Files

From Q
Jump to: navigation, search
Related Online Training modules
Multiple Data Files in a Q Project
Generally it is best to access online training from within Q by selecting Help > Online Training

You can analyze multiple data files at the same time. Additional data files are added by selecting File > Data Sets > Add to Project. Charts can be created using data from different data files provided that both files contain a Date question with identical variable names and question names. The relationships between data files are set using File > Data Sets > Relationships.

A Q project may refer to multiple data files at once. When a project has two or more data files, these extra things are available in Q:

  • Multiple Variables and Questions tabs; one for each data file.
  • Multiple Data tabs; one for each data file.
  • The ability to have tables and charts from different data files intermixed in the Outputs Tab.
  • The ability to have a table/crosstab that simultaneously shows data from two different data files. (Read on to find out how to achieve this.)
  • The ability to have a Time Series Plot that simultaneously shows data from two different data files. (Read on to find out how to achieve this.)

Contents

Adding Multiple Data Files

Once you have a project with one data set, use File > Data Sets > Add to Project again to add another file. You will then see the extra things listed above.

Crosstabbing Multiple Data Sources

Once you have a project with two data files, you have the ability to crosstab two questions from the separate data files. When you try and create crosstabs from questions in separate data files, you may be warned that: You cannot crosstab questions from different data sources that do not have a relationship. First set up a relationship by clicking File > Data Sets > Relationships. To get past this message you must have specified the relationship between the two data files (see Edit Data File Relationships).

The sample size of the table now represents the number of respondents in the matched data.

If you wish to filter the table, and the relationship is Many-to-many, there must be a filter variable with the same Name and Label in both data files.

Charting a Time Series With Multiple Data Sources

Once you have a project with two data files, you have the ability to chart a time series that shows data from both data files.

The following prerequisites must be met:

  • There must be a Date question in both data files with:
    • The same Variable Name,
    • The same Question Name,
    • The same Question Type (Date).
  • If you wish to filter the Time Series chart, there must be a variable with the same Name and Label in both data files. The F.png tag must be turned on.
  • If you wish to weight the Time Series chart, there must be a variable with the same Name and Label in both data files. The W.png tag must be turned on.

With the above prerequisites met, you may create a Time Series chart with multiple data sources by following these steps:

  1. Click Create > Charts > Chart
  2. Select Time series chart and click OK.
  3. Set the brown dropdown (the X axis) to the Date question that exists in both data files.
  4. Set the first blue dropdown (the first Y axis) to a question from the first data file.
  5. Set the second blue dropdown (the second Y axis, on the right) to a question from the second data file.
  6. If you wish to filter or weight your data, select the variables in the filter and weight dropdowns.

See also

Panel Data

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox