Teach Yourself Q in a Few Hours

From Q
Jump to: navigation, search

This training program is designed to give a comprehensive introduction to Q's most fundamental features. You should complete the training program by following the topics in order. In each section you will find a list of Online Training tutorials, which you should complete, as well as a list of links to further reading on the topic in which you can find additional documentation.

To access the training modules you should open Q and then select Online Training from the Help menu. This will open a browser window that contains a menu of Training modules. Selecting a module will open an additional browser window containing instructions for you to complete. You will be alerted if a step is not completed correctly, and if you are stuck on a particular step then you can click the Show me link and Q will demonstrate the step for you.

Q projects

To begin working with your data in Q you must first import a data file by selecting File > Data Sets > Add to Project > From File.... When you import your data file Q will inspect the file and ask you if you want to automatically detect the file structure or use the original file structure. It is generally best to leave the default selection and click OK here. If you wish, you can also specify a range of additional data cleaning functions by clicking the Advanced button.

When the data is imported, Q creates a project file (.Q) to store your work, and you can save the project file to your computer by selecting File > Save. Once you have saved your work in a project file and closed Q you can return to your work by opening Q and selecting File > Open > Existing Project....

All of your work is kept completely separate from the data file. This allows you to update your project with new data when you receive additional records. This means that the project file depends on the data file in order for you to view the project, and so if you want to share your work with someone else you should be sure to send them a QPack, which is a bundle of the project file and the data file. You can save your project as a QPack by going to File > Save As and then selecting .qpack as the desired file format.

Training modules

  • Fundamentals > Starting and Sharing Projects > Starting Projects
  • Fundamentals > Starting and Sharing Projects > Creating a Q Pack

Further reading

The User Interface

You will become familiar with Q's user interface as you complete the Online Training modules in this training program. Q's four tabs, Outputs, Variables and Questions, Data, and Notes, separate the distinct areas of the workflow. As with other Windows software packages, there are a number of menus at the top of the Q window which group Q's features into categories of similar tasks, and most objects in Q's user interface can be right-clicked in order to obtain a context menu for that item which contains additional options.

Training modules

  • Fundamentals > Creating Tables > Tabs

Further reading

  • The Outputs Tab is where you can build your report and analyse your data.
  • The Variables and Questions Tab provides you with a list of the variables in your project. This is where you can generate new variables questions, and change the properties of existing ones.
  • The Data Tab provides you with a view of the raw data in your project.
  • The Notes Tab provides a space for you to keep notes about your work.
  • User Interface provides a list of Wiki pages for the various user interface elements in Q.

Question Types

In Q, the variables from your data file are arranged as Questions, with multiple response questions containing a number of related variables. The concept of Question Type is the means by which Q decides how to interpret and display your data. Q's question types are designed to reflect the way you would ask a question in your questionnaire. This training program will take you through examples of the most commonly-used question types, and it will show you how to change between question types when you want to view your data differently.

Training modules

  • Fundamentals > Creating Tables > Question Types and Statistics

Further reading

  • Question Types provides a description of each of Q's Question Types, and examples of how the questions would be asked in a questionnaire.

Table Manipulations

The Outputs Tab is where you will perform most of your analyses. Here you can create and organize tables and charts. The Blue and Brown Drop-down Menus are used to select which questions you want to display in your table. Selecting a single question in the blue drop-down menu will provide you with a Summary table for that question. Selecting a second question from the brown drop-down menu will create a crosstab. The Footer at the bottom right of your table provides information about the sample and some details about the significance testing.

Q allows you to arrange the display of your results directly from the table. This includes merging, renaming, and removing categories, as well as creating NETS. These are achieved by dragging and dropping items on the table, or by right-clicking items on the table and selecting options from the context menu. Importantly, when you make changes to a table for a particular question then these changes will be reflected on any other table that also uses that question. Consequently, if you wish to display the same question in different ways you must make an additional copy of the question. The easiest way to copy a question is to right-click on one of the rows in the table and select Duplicate Question.

The statistics that are shown in the table can be selected by right-clicking on the table and selecting options from Statistics - Cells, Statistics - Right, and Statistics - Below.

Training modules

  • Fundamentals > Creating Tables > Tables and Crosstabs
  • Fundamentals > Creating Tables > Merging Categories
  • Fundamentals > Creating Tables > Creating NETs
  • Fundamentals > Creating Tables > Re-basing Tables
  • Fundamentals > Reports > Creating Reports

Further reading

Filters

Filters are variables that are used to select a specific group of your sample for analysis. Respondents who are not selected by a filter are removed from the base sample of the table.

Filters are applied to a table using the Filter drop-down menus below the table. Once a filter has been added, an additional drop-down menu will appear so that you can select multiple filters. Filters combine together in an AND relationship, meaning that applying two filters to a table will select respondents who are selected by both filters.

Training modules

  • Fundamentals > Filters > Applying a Filter
  • Fundamentals > Filters > Setting Filters in the Variables and Questions tab
  • Fundamentals > Filters > Simple Filters
  • Fundamentals > Filters > Complicated Filters

Further reading

  • Filters provides a list of methods that can be used to create filters.

Significance Testing

Q conducts a significance test for each cell in a table by default. The results are denoted with arrows, and blue and red coloring of the font. Blue denotes results that are significantly high, and red denotes results that are significantly low. This kind of testing is referred to as Automatic Tests Of Statistical Significance. The type of test that is used for a particular table is determined by the data that is shown in the table, as well as the options that have been chosen for statistical testing.

An alternative to the automatic tests of significance is the Column Comparisons testing, where significance tests are conducted between the columns in the table. This kind of testing can be turned on by selecting Column Comparisons from the Statistics - Cells and Column Names from the Statistics - Below. Each column in the table is assigned a letter of the alphabet, significantly high results are denoted by the placement of letters within cells.

To change the settings that are used for significance testing for your entire project you should make changes in the Statistical Assumptions tab in Edit > Project Options > Customize.... To change the settings that are used for an individual table (and override the project settings) you should make changes to the same settings within Edit > Table Options.

Training modules

  • Fundamentals > Significance Testing > Automatic Tests Of Statistical Significance
  • Fundamentals > Significance Testing > Type 1 Error
  • Fundamentals > Significance Testing > Planned Tests Of Statistical Significance
  • Fundamentals > Significance Testing > Column Comparisons

Further reading

Setting Questions

When you import your data Q will combine variables into questions based on the structure of the data. In some cases you will need to combine variables in other ways, for example if you construct a new set of variables. To split up the variables in a question you can highlight the variables in the Variables and Questions tab, right-click, and select Revert to Source. To combine a set of variables into a new question, highlight those variables in the Variables and Questions tab, right-click them, and choose Set Question. You will then be prompted to give a name to the new question and to choose the Question Type for that question.

Training modules

  • Manipulating Data > Questions > Changing a Pick Any - Grid to a Pick Any question
  • Manipulating Data > Questions > Combining different variable types to a Pick Any - Grid

Further reading

Question Manipulations

Two of the key ways that you can change the way Q interprets and displays the data from a given question are to change the Question Type of the question, and to edit the Value Attributes of a question. By changing the Question Type of a question you can alter the way Q interprets and displays the data from that question. By editing the Value Attributes you can modify the metadata for a question, including the numeric values that are used to compute averages, as well as which categories are displayed and counted in the table.

Changes of Question Type are performed by clicking in the Question Type column in the Variables and Questions tab and selecting an option from the menu. A common example where changing Question Type is particularly useful, is the case where you have a Pick One - Multi question (say a five-point-scale) and you would like to create Top 2 Box scores for each item in the question, or to display an average score for each item in the question. This example is covered in the Training modules below.

The Value Attributes of a question can be edited by right-clicking on a table showing the question and selecting Values, or by locating the question in the Variables and Questions tab and clicking ValuesButton.png. You will also be prompted to inspect the Value Attributes when changing a question to the Question Types of Pick Any and Pick Any - Grid.

Training modules

  • Manipulating Data > Questions > Multiple Response Questions
  • Fundamentals > Creating Tables > Re-basing Pick Any Tables
  • Manipulating Data > Recoding Numeric Data > Editing Values
  • Manipulating Data > Recoding Numeric Data > Recoding Ranges of Values
  • Manipulating Data > Solutions to Common Problems > Changing Part of a Question

Further reading

Grid Questions

Where a multiple response question is looped over a number of brands or attributes the variables can be combined into a Pick Any - Grid question so that the results for each part of the loop can be shown on a single table. Q determines the layout of the grid from the labels of the variables. The modules below provide examples of grids that have been set up correctly and an example of how to fix labels when they have an incorrect structure.

Training modules

  • Fundamentals > Advanced Question Types > Grids
  • Manipulating Data > Questions > Grids
  • Manipulating Data > Solutions to Common Problems > Poorly Set Up Grids

Banners

To combine multiple demographic questions so that you can show them all in the same crosstab you can create a Banner question. This is done by selecting Create > Banner > Drag and Drop....

Training modules

  • Fundamentals > Banners and Spans > Combining Questions
  • Fundamentals > Banners and Spans > Nesting Questions
  • Fundamentals > Banners and Spans > Creating Headings

Further reading

Exporting

Once you have created your report you will need to export it so that you can communicate your results. Q has a number of options for exporting, including exporting tables and charts to Microsoft PowerPoint, Excel, and Word, and as a PDF document.

You can initiate an export to Office by selecting one or more items in your Report and then clicking one of the export buttons (OfficeExportButtons.png) in the toolbar above your table or right-clicking in the report tree and selecting Export To Office. You can export to each Office program as either a table or chart, and the options available depend on which program you select. If you wish to export a table as a chart, the best option is to use the Excel Chart format option for whichever Office program you are exporting to.

Exports to Excel and PowerPoint can be updated with new data, which is particularly useful when you need to update a report for a tracking study, or when you need to produce similar reports for different segments. The option to update an existing Excel or PowerPoint document becomes available if you open a document to which you have exported previously.

When choosing a Chart type for your export, you can select a chart template that you have created in PowerPoint or Excel. This means that you can apply the same formatting options to multiple charts during your export, avoiding the need to format each chart manually.

Training modules

  • Fundamentals > Exporting > Exporting Charts and Tables to Office
  • Fundamentals > Exporting > Default Export Charts Office 2007/2010
  • Fundamentals > Exporting > Updating Embedded PowerPoint Charts in a Tracking Study
  • Fundamentals > Exporting > Creating PDFs

Further reading

Batches of Tables

Q has two features for creating Batches of tables, and these are available in the Create > Tables menu. The Basic Tables options allows you to create a set of cross tabs by specifying lists of questions. The Smart Tables option allows you to to find interesting results quickly. Smart Tables creates a set of crosstabs with one key question, and the resulting tables are ordered according to the significance of the relationship that is determined for each crosstab. In both cases the crosstabs are added to your report tree, and the tables are organised into groups.

Training modules

  • Fundamentals: Reports: Basic Tables
  • Fundamentals: Reports: Smart Tables

Further reading

Date Questions

The Date question type has some useful properties that make analyzing time-series data quick and easy. In particular, when you have a crosstab involving a Date question you can quickly change whether your data is shown weekly, monthly, or quarterly, and you can easily choose which range of date you wish to display in the table.

Training modules

  • Fundamentals > Dates and Time Series > Setting Date Scales
  • Fundamentals > Dates and Time Series > Time Series Plots

Further reading

Updating Projects With New Data

The work in your Q project file is kept entirely separate from the data. This means that if you obtain an updated data file, containing the next wave of data from a tracking study for example, you can update your project with the new data file and your work will be applied to the new cases. This process relies on your new data file being complete. That is, it should contain the new cases as well as the original cases. If this is not possible, then it is possible to Merge data files in Q.

Updating an existing project requires your new data file to be formatted in the same way as the previous data file so that Q can match the variables and interpret the data consistently. When you update your project with a new data file, Q will alert you to any problems caused by changes in the data file.

Training modules

  • Fundamentals > Starting and Sharing Projects > Updating Data
  • Fundamentals > Dates and Time Series > Updating Tracking Projects

Further reading

Creating Charts

Any table can be turned into a chart by selecting a chart type from the Show Data as menu above the table. Formatting options for the various elements of the chart are accessed by right-clicking. To save the format of your chart as a template you can click the save icon to the right of the Show Data as menu. The template can then be applied to another chart or table by selecting Use Template from the very top of the Show Data as menu.

Training modules

  • Fundamentals > Plots > Switching From Tables to Plots
  • Fundamentals > Plots > Plot Templates

Further reading

  • Chart Types lists the available chart types and the kinds of data to which they apply.
  • Charts describes the formatting options that are available on your charts.

Coding Text Data

In many cases your questionnaire will have questions that give respondents the opportunity to enter open-ended responses. This kind of data typically ends up in one or more Text questions. You can display the responses by selecting a Text question in the Blue drop-down menu, but you will probably also want to categorize the text information so that you can view statistical information about the responses. Responses can be assigned to categories using Q's coding feature, which is accessed from the Variables and Questions tab by selecting one or more Text questions, right-clicking, and selecting Insert Variable(s) > Code Text > New Code Frame....

The Question Type of the question that results from your coding will depend on whether you select one or multiple Text questions as the input to the coding, and whether or not you ask Q to assign each response to one category or to multiple categories.

Open-ended responses from 'Other/Specify' categories can be combined into the original question using Back Coding.

Training modules

  • Manipulating Data > Coding Text Data > Coding Text Variables
  • Manipulating Data > Coding Text Data > Back-coding
  • Manipulating Data > Coding Text Data > Coding Spontaneous Awareness

Further reading

  • Coding provides a complete description of the coding process, including how to ensure that you obtain the correct Question Type for the coded question.

Weighting

You can specify variables to use to weight your data. You can also construct new weight variables by providing weighting targets for questions in your data file.

Training modules

  • Fundamentals > Weights > Applying weights
  • Fundamentals > Weights > Setting a Weight in the Variables and Questions tab
  • Fundamentals > Weights > Creating a weight with multiple variables
  • Fundamentals > Weights > Creating a weight by wave

Further reading

Hints and Tips

There are a number of additional time-saving hints and tips that can be helpful to new users, and we list some of them here.

  • Keyboard Shortcuts contains a list of all of the available keyboard shortcuts in each tab.
  • The blue arrow located to the right of the blue and brown drop-down menus will highlight the current question in the Variables and Questions tab.
  • The blue arrows located to the right of variables in the Variables and Questions tab will show you the variable in the Data tab.
  • Double-clicking the row number of a variable in the Variables and Questions tab will replace the question in the blue drop-down menu of the table that is selected in the Outputs tab with the question that was clicked.