Project Templates

From Q
Jump to: navigation, search

The settings in Project Options can be saved into templates so that you can easily apply them to your different projects without needing to write down your preferred settings or go back to your old projects to check the settings. This is particularly useful for keeping your preferred statistical testing settings (Statistical Assumptions) consistent between your projects.

Saving a Template

To save your own preferred settings as a project template:

  1. Open or create a project.
  2. Ensure that the settings in Project Options are as you require.
  3. Select New items for any Rules that you wish automatically applied in new projects.
  4. Select Edit > Project Options > Save As Template. Be sure to save the template file into the "Built-in Templates" sub-folder within your Q program directory (eg: C:\Program Files\Q\Built-In Project Templates).
  5. Choose a name for the template and click Save.

Templates in Q5

To apply a template to your current project you can select Edit > Project Options > Apply Template. This will replace whatever options you have currently chosen within the Project Options with the options from the template.

Built-in Templates

There are three built-in templates for the Statistical Assumptions section of the project options, which correspond to the most common preferences for statistical testing.

Standard Q (False Discovery Rate)

These options are Q's standard default settings. If you do not apply a template then these are the settings you will get when starting a new project.

In particular:

  • The Overall significance level is set to 0.05.
  • The levels for lowercase and uppercase letters in the Column Comparisons tests are 0.05 and 0.001, respectively.
  • The Multiple Comparison Correction is applied to tables, and the correction that is used is the False Discovery Rate.

QDefaultSettingsTemplate1.png

Testing at 95% Level of Confidence

These settings are the same as for the Standard Q template, except that the Multiple Comparison Correction is turned off.

Traditional crosstab

These settings are designed to more closely match older styles of crosstab software. In particular they apply the statistical tests used by Quantum.

These settings use a significance level of 0.05 and have a single set of uppercase letters to denote the results of Column Comparisons. No Multiple Comparison Correction is applied, and the Kish approximation is used when dealing with weights.

TraditionalCrosstabSettingsTemplate1.png

Applying a template

To apply a template in a new project, go to Edit > Project Options > Apply Template and select the saved template file.

Default templates are set using Edit > User Options > Templates and selecting your preferred default.

In Q 4.11

To create a project template, which will be applied when creating new projects:

  1. Open or create a project.
  2. Ensure that the settings in Project Options are as you require.
  3. Select New items for any Rules that you wish automatically applied in new projects.
  4. Select File > Save Project As Template.
  5. Choose a name for the template and click Save. The template will be saved into a directory named something like C:\Users\oliver\AppData\Roaming\Q\Templates\Projects.
  6. Next time you create a new project Q will offer you the chance to use this template.

General Notes

  • You can have multiple project templates.
  • You can manually copy template files from another user onto your own computer. The easiest way to find the correct location is to use Edit > Project Options > Save as Template and observe the directory it shows.
  • You can change the directory used for templates to a network drive (for example) by setting CurTemplateDir in the registry key HKEY_CURRENT_USER\Software\Q. This will affect both chart templates and (in a Project subdirectory) project templates. Please note: you should not modify this setting unless you fully understand registry settings, as it is the type of thing that if you play around without having the relevant expertise you could inadvertently cause a lot of problems on your computer.

See Also