System Requirements

From Q
Jump to: navigation, search
Computer and processor 1 gigahertz (GHz) processor or higher. For large projects a 64-bit processor and 64-bit edition of Windows is recommended.
Memory 2 gigabytes (GB) of RAM or higher.
There are more specific recommendations if Working with Large Data Files.
Hard disk 200MB available disk space. More is necessary if you do not already have the .NET Framework installed.
Display 1024 x 768 or higher-resolution monitor. At 1024 x 768, a maximum of 96 DPI (or 100% font scaling) is supported.
Operating system* Windows Vista with Service Pack 2, Windows 7 with Service Pack 1, Windows 8, Windows 8.1, or Windows 10.
For large projects 64-bit editions of Windows are recommended.
Internet An Internet connection is required for the use of the online training system and for transferable licenses. If you have extra firewall or network security as part of your systems then it must allow Q to use HTTP (port 80) and HTTPS (port 443).
Additional software Q 4.11 and earlier require Microsoft .NET Framework 4.0 or later. This is included with Windows 8 and Windows 10. It needs to be installed for Windows Vista and Windows 7. The Q setup wizard will automatically install the .NET framework if it is not available.

Q 5 and later require Microsoft .NET Framework 4.5 or later. This is included with Windows 8 and Windows 10. It needs to be installed for Windows Vista and Windows 7. The Q setup wizard will automatically install the .NET framework if it is not available.

To export tables or charts to Microsoft Office, you must have Microsoft Office 2010* or later installed. Since Q 4.11.2, if you do not have Office installed, you may still export tables to Excel files (.xlsx) using the Export to Excel (fast) feature.
Other Q can only run on Apple Macs within Parallels or other Windows emulation software.

To use Q Professional on a Terminal Server, you must purchase a Transferable license.

* We support Microsoft Windows and Microsoft Office versions until they are ten years old. Q may work with older versions, but we make no guarantees.

For more information contact support.

Contents

Terminal Server

  1. Connect to the Terminal Server as an administrator.
  2. Go to your Customer Page.
  3. Find a free transferable license (a green row that says "Transferable") and click Check Out Q Professional
  4. On the next page, click Install Q Professional and install the program that you download. This will also install the transferable license.
  5. Connect to the Terminal Server as a normal user and verify that you can check out a license.

For System Integrators

This information is provided for the benefit of IT people who need to assess Q or make it part of their standard builds.

  • If virtualizing/packaging Q for deployment, run QSetup.exe but do not install a license. Q will start as "Q Reader" because no license has been installed. Licenses must be installed by Q on each user's machine, and will need to be reinstalled annually upon renewal. You will need to instruct users to visit their Customer Page to install the license.
  • For automatic deployment, the installation program (QSetup.exe) can be run with the "/silent" parameter. For this to work properly you must ensure that it runs as an administrator and that no old versions of Q are still running.
  • On a 64-bit edition of Windows, Q must be installed into C:\Program Files\Q, because it will install 64-bit binaries. It must not be installed into the 32-bit program files directory.
  • C:\Program Files\Q\License.lic requires special permissions: it must be writeable by "Everyone". This ensures the license is shared between users on the same physical computer (doesn't use Roaming settings).
  • So that these special permissions don't get lost, the C:\Program Files\Q\License.lic file must always exist (even if it has a size of 0) and shouldn't be deleted.
  • Licenses:
    • Standard license: This can not be bundled in the install. When the user activates Q, the C:\Program Files\Q\License.lic file is modified to include a hash of the machine's hardware IDs.
    • Transferable license: This can be bundled in the install. The transferable license registration is stored in the %ALLUSERSPROFILE%\Q directory and should be bundled with the install. When the user checks out a license, the license file is temporarily stored in the user's local profile directory.
  • Q installs everything into its own directory in Program Files, except for:
    • The %ALLUSERSPROFILE%\Q directory (e.g. C:\ProgramData\Q), which is given special spermissions (writeable by "Everyone"). This is used for sharing machine-wide settings between all user profiles.
    • RtoQ.dll, which it installs into C:\Windows\System32. This DLL is used by the R program if integration between the two is required. Otherwise it may be omitted.
  • Q installs registry entries for its own file extensions, but does not modify registry entries created by other programs.
  • Q does not replace any shared DLLs.
  • Q "drives" (via COM) Microsoft Office when exporting tables and charts. Q will only talk to Office when you export, so it cannot discombobulate office in other situations. Q has been tested with Microsoft Office 2000, 2002, 2003, 2007, 2010 and 2013.
  • Q's online training runs as an in-built web server in the Q.exe process that listens on port 21403, bound to localhost only. The web server is only started on-demand when the user clicks the “Help > Online Training” menu item – so it is not required for normal operations. On Windows Vista and later, QSetup.exe runs the following command to allow unprivileged user access to bind this port: {system32}\netsh.exe http add urlacl url=http://localhost:21403/ user=Everyone
  • We are not aware of any conflicts between Q and other applications.

Citrix

Restricted drive/folder access

If you have restricted access to the C: drive or Program Files folder, you need to change your installation procedure to add 2 extra steps:

  1. Change the default directory for opening files. In the registry key HKEY_CURRENT_USER\SOFTWARE\Q set a string value with name CurrentProjectDirectoryName to an accessible directory. To test the change, open Q and select File > Open > Existing Project - if you see a standard Windows file dialog, it is working. Background: The default directory for the File Open dialog is C:\Program Files\Q\Examples. This will cause problems if you have restricted drive/folder access, and may mean that users cannot open files via the File menu.
  2. Copy the Q example files from C:\Program Files\Q\Examples into the above directory. Background: Q installs its example files into its installation directory. If you have restricted drive/folder access, it means that users cannot access the example files.
Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox