Search

From Q
Jump to: navigation, search

The Search box is located to the right of the drop-down menu bar in Q. By default, it says Search features and data.

Overview

This is a great way to find menu options or documentation when you can recall the name of what you want to do, but cannot recall where to find it in the menu system. Similarly, it can help you find your variables and questions much more easily than scrolling through a long list on the Variables and Questions tab.

It can be used to search through:

  • Tables and outputs (on the Outputs tab)
  • Variables, questions, and value labels (on the Variables and Questions tab)
  • Your data (on the Data tab).
  • All the menus of Q - to help you find functions or settings.
  • The online training modules.
  • The Online Library - for finding rules and functions.
  • Documentation (i.e., performing a search on this wiki) - to help you find more information.
  • For initiating a Find Replace - for quickly updating labels and text in your project.

SearchExample2 v3.png

Tables, outputs, variables, and questions

You can search for tables or variables and questions by typing in a search term and then selecting Find '[search term]' on this screen. If you're on the Outputs tab, Q will search through tables in your Report tree. If you're on the Variables and Questions tab then Q will search through your variables and questions. The results will be returned in a window at the bottom of the screen and you can click items in these results to go straight to where they can be found in your report or among your variables.

Selecting the Advanced Find/Replace will open up the advanced Find Replace dialogue.

Data

If you conduct your search whilst on the Data tab, then selecting Find '[search term]' on this screen will search through the data points in your file. The search results are returned in a list at the bottom of the screen, and clicking a result will take you to that specific point.

Menus

Results returned under the Menus, when selected, will run the menu option. This is particularly handy if you can remember the name of the function you want to run, but not where to find it in the menus. For instance, if I search for "Hide rows columns" and then select the search result under Menus called "View -> Hide Empty Rows/Columns" then that will run the function.

Training

These results refer to the specific module in Q's Online Training system. Selecting one of these will take you to that particular module.

QScripts and Rules

Results returned under this heading will contain any relevant QScripts and Rules that you can run, most often from within the Automate menu and the Online Library. Selecting the result here will run the function directly.

Documentation

The results under the Documentation heading come from the Q-wiki - the very site you're reading this on. You can search through all the documentation available here.