Integrating PowerPoint Exporting Into Your Workflow

From Q
Jump to: navigation, search

Contents

Setup for creating single-chart slides

Q's exporting processes have been principally designed for creating slides that contain a single chart or table, such as the the one shown below. The process for automating the creation of such slides is:

  • If using a slide master to control the appearance (e.g. fonts, borders, logos, etc) of the PowerPoint slides, create an appropriate PowerPoint document (.ppt) and distribute it to everybody that needs to use it.
  • Create Chart Templates for each type of chart you wish to create.
  • Distribute the templates to everybody that needs to use them by either:
    • Placing them in a central location and specifying this location in the Template directory in Edit > User Options > Export Chart Defaults (this needs to be done on each installed version of Q).
    • Using the default Microsoft Office template directories and copying the template files (.crtx) between computers.
  • Modify the PowerPoint Export Layout settings. These are saved as a part of Project Templates.
  • If appropriate, set default templates for different combinations of data. (See Edit > User Options > Export Chart Defaults. This needs to be done on each computer on which Q is installed.)

SingleSlide.PNG

Business rules

If the people with final responsibility for creating the PowerPoint slides are different to the people conducting the analysis in Q, it can be useful to create a set of business rules describing how Q should be used so as to make the task easiest (e.g., a document on an intranet). Some examples are provided below.

Computer setup

  1. If not storing templates in a central location, copy the templates to the appropriate directory on the user's computer.
  2. If using Project Templates, save them onto the user's computer.
  3. If appropriate, set default templates for different combinations of data. (See Edit > User Options > Export Chart Defaults. This needs to be done on each computer on which Q is installed.)

Project setup

If customizing footers using the settings in Footers, set these up on the first table when starting a new project in Q.

Slide design rules

That is, a set of rules indicating which type of slide designs should be used in which situations.

Multiple separate charts on a page

  • Create a folder in Q representing a single slide (i.e., PowerPoint page), using the desired title for the slide as the name of the folder in Q.
  • Create instructions about the desired layout using Create > Text (this will be exported as a single page in PowerPoint). For example: Layout in two rows, with two per row.
  • Either:
    • Export each of the tables to PowerPoint, setting Format to To PowerPoint as Excel Chart and Chart to the appropriate template.
    • If the intent is that somebody will export at a later time, select Edit > Table Options and specify Format to To PowerPoint as Excel Chart and Chart to the appropriate template.

MultipleSlidePerPage.PNG

Creating a chart from multiple tables

  • Create a folder in Q representing a single slide (i.e., PowerPoint page), using the desired title for the slide as the name of the folder in Q.
  • Create instructions about the desired layout using Create > Text (this will be exported as a single page in PowerPoint). For example: Layout as a stacked column chart, with blank columns separating the different data.
    • Export each of the tables to PowerPoint, setting Format to To PowerPoint as Excel Worksheet.
    • If the intent is that somebody will export at a later time, select Edit > Table Options and specify Format to To PowerPoint as Excel Worksheet.

See also

Exporting to PowerPoint

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox