How To Merge New Cases

From Q
Jump to: navigation, search

If you have received a partial data file that only contains some cases that you now need to merge into your master data file, then Q can help you merge these files together. The menu option for this is found under Tools > Merge Data Files > Add New Cases.... The steps to merge two files together follow here.

Process

Where File A is the data file (.sav) in your current Q project, and File B is the new data file that contains additional cases:

  1. Open Q, start a new project, and load File A.
  2. When prompted, select Use original data file structure.
  3. Go to Tools > Merge Data Files > Add New Cases...
  4. When prompted, click Browse for the Donor data file and select File B.
  5. Decide which file you would prefer in case of conflict. For full details on the selection and the consequences, see Which File to Prefer
  6. Click Merge Files.
  7. You will get a large dialogue with variables that match and that don't match between the files. You can drag and drop variables here in the columns with variable names to match up ones that haven't been identified automatically, or if you know that one variable should match another but is listed as new or additional. See How to Merge for further details.
  8. For any conflicts, make sure you click the Accept button.
  9. When done, click Save.
  10. Save the file using a new file name (careful not to save over any of your existing files).
  11. Close this project.
  12. Open your main project.
  13. Go to File > Data Sets > Update > [name of current file]
  14. Select the file you saved in step 10.