How To Merge Data Files In Different Languages

From Q
Jump to: navigation, search

Q contains internal safety mechanisms when using Tools > Merge Data Files > Add New Cases that can cause problems when merging data files written with labels in different languages. For example, if gender in one file is shown in English in one file as 1: Male and 2: Female, but is shown in a second data file in Polish as 1: mężczyzna and 2: żeński, Q will combine the variables so that you end up with 1: Male, 2: Female, 3: mężczyzna and 4: żeński. A simple solution to this is to merge the categories in the newly-created merged data file, but this is very time consuming. An alternative is to:

  1. Choose one file as the master file whose labels will be used in the integrated data file.
  2. Select File > New Project.
  3. Select File > Data Sets > Add to Project > From File and import the other file.
  4. In the Data Import Window:
    1. Select Use original data file structure.
    2. Untick Tidy Up Variable Labels and Strip HTML from Labels.
    3. Click OK.
  5. Tools > Save Data as SPSS/CSV File and save it as a CSV data file.
  6. Select File > New Project.
  7. Select File > Data Sets > Add to Project > From File and import the CSV file.
  8. In the Data Import Window:
    1. Select Use original data file structure.
    2. Untick Tidy Up Variable Labels and Strip HTML from Labels.
    3. Click OK.
  9. Tools > Save Data as SPSS/CSV File and save it as an SPSS data file. This data file will no longer contain any Value Labels.
  10. Select File > New Project.
  11. Select File > Data Sets > Add to Project > From File and import the master file.
  12. In the Data Import Window:
    1. Select Use original data file structure.
    2. Untick Tidy Up Variable Labels and Strip HTML from Labels.
    3. Click OK.
  13. Tools > Merge Data Files > Add New Cases
  14. Press Browse and select the new file you just created as the Donor data file.
  15. Select Prefer current file for To Resolve conflicts and press Merge Files.
  16. Press Save and save the new file.
  17. Select File > Data Sets > Update, choose your master file, and update it with the newly-saved file.

Obtaining correct question names

In Q4.9.7 and earlier versions, some Question Names for multiple response questions may not appear correctly when this method is used to merge files. In this case some extra steps are necessary to correct the question names.

For example, applying the above process results in the following change for the question Q6. Brand preference:

QuestionNameLoss.PNG

The correct question name information has been lost, and the resulting name is $Q6. Similar issues exist for other multiple-response questions in the project.

The solution is, having completed the steps above, to:

  1. Use File > Import New Data File (New Project) to import the master file, selecting Yes to any questions you are asked.
  2. Use File > Data Sets > Update to import the newly-merged data file that was created in the steps above.
  3. Click Accept to the dialogue presenting any new variables that have been added in the process above.

All question names will now match those from the original data set.

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox