How To Detect Changes in Trackers

From Q
Jump to: navigation, search

The following process describes how to efficiently scan through a tracking project to detect changes over time.

Step 1: Creating a time variable

Detecting change at a point in time

Where the goal is to detect change at a particular point-in-time, such as from January to February, or, 2016 to 2017, a binary variable needs to be created that reflects this point in time. This is done as follows:

  1. Create a SUMMARY table, with a question in the Blue Drop-down menu that contains a variable which indicates dates or waves.
  2. Right-click on the cell, or cells, that show the data for the last wave of interest. In the example below, interest is in comparing how Jan-Mar data differs from Oct-Dec.
  3. Select Create Filter.
  4. Enter a name that you find useful (e.g., 1st quarter 2016).
  5. Ensure that Apply filter to the current table is not checked.
  6. Press OK.

LastWave.png

Detecting trend

Where the goal is to look for trend, such as identifying data that has on average increased consistently over a six month period

  1. Identify either a:
    • Date variable.
    • A wave variable, that contains sequential numbers indicating each wave (e.g., 1 for January 2012, 2 for February 2012, ... 13 for January 2013, etc.).
  2. Copy it.
  3. Set its Question Type to Number.

Step 2: Shrinking the data file

This step is designed to make the computations fast, by deleting any data that is not relevant.

  1. Save your project.
  2. Select File > New Project.
  3. Select File > Data Sets > Add to Project > From File.
  4. In the Data Import Window:
    1. Select Use original data file structure.
    2. Untick Tidy Up Variable Labels and Strip HTML from Labels.
    3. Click OK.
  5. Select the data file that you have been analyzing.
  6. Create a filter of all observations that you wish to to exclude from your analysis. For example, if you are wanting to compare data in March with data in February, create a filter that contains all cases that are in neither March nor February of the year of interest. If you are not familiar with how to do this, see filters or the description below of Detecting change at a point in time.
  7. Go to the Data tab. If your data file is large, this may take a while. If asked, click Continue to Data Tab.
  8. Select a an ID variable in the Case IDs drop-down. If it is your only option, select Use case number. However, you should look to getting a new data file that contains a unique ID variable for this project, as it will save a lot of time when performing data cleaning.
  9. In the Filter drop-down at the bottom of the screen, select the filter of observations to be excluded.
  10. Right-click on one of the row numbers.
  11. Select Delete Rows Matching Filter (Green). With large data files this may take a while. Avoid attempting to repeat the process if it is slow and unresponsive.
  12. Tools > Save Data as SPSS/CSV File and pressing OK.
  13. Enter a name. E.g., Last two months and press Save.
  14. File > Open > Recent Projects and select the project saved in point 1.
  15. File > Data Sets > Update.
  16. Select the file create earlier, and press OK and Accept.
  17. File > Save as and give the file a new name, so that you do not inadvertently save it on top of the old file.

Step 3: Smart tables

  1. Automate > Browse Online Library > Hide/Unhide >Hide Large Questions
  2. Create > Tables > Smart Tables
  3. Set Output dependent question in to Brown drop-down (columns).
  4. Specify any filter or weight variables.
  5. Set Output dependent question in to Brown drop-down (columns).
  6. Select the variable created in Step 2 as the Dependent question.
  7. Select any variables that you are interested in as your Independent questions. Note that Smart Tables is a highly computationally-intensive technique, so if you select everything, and have a huge data file, you will either wait a long time, or, if your computer has insufficient memory, may get a bug.
  8. Press OK.

Step 4: Trend plots or tables

Where any tables contain too many results for you to read, change Show Data as to Miscellaneous > Trend Plot.