Category:Panel Data

From Q
Jump to: navigation, search

Panel data is data where there are multiple observations for each individual on the panel. Common examples include:

  • Customer satisfaction panels, where the same customers provide ratings of satisfaction over time (e.g., every quarter).
  • Television viewing panels, where people’s TV viewing is recorded over time.
  • Household purchasing panels, where households purchases are recorded over time.
  • Customer records and transactional records (e.g., where an online book seller records each purchase of its customers).

Data from a panel can be stored in two separate databases: an individual-level database which contains general characteristics of the members of the panel (e.g., the size of the household, its annual income) and the situational database, which records the behavior or opinions of the panel in different situations (e.g., at different points in time).

This and the related pages of documentation describe how to jointly analyze individual-level databases and situational databases using Q. All the examples can be found in c:\Program Files\Q\Examples\Panel.Q (the path may be different on your computer if Q has not been installed in the default location). In this project the individual-level database records the characteristics of a sample of households as recorded in a data file called Households.sav and the situational database contains the transactions of the households, as recorded in a file called Transactions.sav.

Creating, importing and linking the databases

Related Online Training modules
Multiple Data Files in a Q Project
Generally it is best to access online training from within Q by selecting Help > Online Training

The general principles for setting up data files in Q are applicable to the setup of panel databases (e.g., it is better to have well setup SPSS .sav files than CSV files ). In addition it is necessary to have a unique identifier variable in both databases which matches the individual-level records with the situational records (e.g., the households with the households’ purchases).

Data sets must be first added to your project using File > Data Sets > Add to Project.

It is often helpful to replace the names with something shorter (this is done by selecting File > Data Sets > Edit Names).

The relationship between the databases is set by selecting File > Data Sets > Edit Relationships, pressing New Relationship and filling out the form, selecting appropriate unique variables for matching the files and pressing OK. If your individual-level database is on the left you should select a One to many relationship; if it is on the right you should select a Many to one relationship. (You may need to first change the Variable Type of your unique identifiers in each data file to Numeric).

Simple tabular analyses

Once the two data files have been added, questions and variables in each data file can be selected in Q’s various drop-down menus. The question names will show the name of the respective data files in square brackets (e.g., Lifestage [Households.sav]). Where crosstabs are created using data from both the individual-level database and the situational database, the individual-level data is stretched and spliced onto the situational data. For example:

PanelData.PNG


See also

Pages in category ‘Panel Data’

The following 4 pages are in this category, out of 4 total.