Ad Hoc Audits of Tables, Variables and Questions

From Q
Jump to: navigation, search

Contents

Understanding merges and nets

Where categories on a table have been merged by dragging and dropping, or, by creating nets, the labels of the categories that have been merged can be seen by hovering your mouse on the categories, as shown below.

HoveringOverCategories.png

Viewing Variable Names and Values (Codes) using Show Variables and Source Values

Right-click on any row or column and select Show Variables and Source Values, which will list the variable names and values. If you click on them, Q will then automatically take you the relevant variables/values in the Variables and Questions tab.

ShowVariablesAndValues.png.

This works for all question types apart from Experiment.

Identifying the questions, weights and filters

When viewing any particular table there are buttons which take you to the questions, filters and weights used to construct the questions. Pressing the RightArrow.png button to the right of the blue and brown drop-downs selects the relevant questions in the Variables and Questions tab. Similarly, pressing either F.png or W.png, located to the left of the Filter and Weight drop-downs on the Outputs Tab, takes you to filter and weight variables on the Variables and Questions tab.

Reviewing the Value Attributes

The Value Attributes of a question are obtained by right-clicking on row or column headings of a table and selecting Values. The specific Value Attributes shown depends upon the Question Type. The example below shows that:

  • The category Less than 18 has been set as Missing Data, which means it is not shown on any tables and is excluded from the base when computing statistics.
  • The category 65+ originally had the label of 65 or more (note that Source Value refers to the original value; in this case, the value in the SPSS data file).
  • The values have been recoded from 2 through 10 to midpoints of the age categories.

ValueAttributesNumeric.png

The example below shows the Value Attributes for a Pick Any question. In this case the Value field is no longer shown (as it does not influence any calculations in a Pick Any question) and the Count This Value field is shown, from which we can check that this question is computed using responses of Once a week through to Every or nearly every day.

ValueAttributesPickAny.png

Interpreting a variable's name

The appearance of the Name of a variable in the Variables and Questions tab indicates how the variable has been created. Where the name is grey (e.g., CellQ2.png) this indicates that this is the name of the variable in the original raw data file. Where the name is black, it indicates the variable has been created in Q, by either:

  • Coding of the text data, in which case the default name will end with a _c (e.g., CellQ1 D c.png).
  • Making an Exact Copy of a variable or question, in which case the variable name will end with an underscore and a numeral. For example, CellQ3 3.png is the third version (and thus second exact copy) of a variable called Q3.
  • Making a Linked copy of a variable, which is indicated by a suffix of _l (e.g., CellQ3 L.png).
  • Creating a new variable in Q, by either creating a filter, creating a weight, inserting a new variable or using a ready-made formula, where the resulting variable is, by default, a name that is a random combination of letters (e.g.,CellbFAGJK.png). Where a new variable has been created, the prefix will, by default, indicate the method of construction. For example:

Edit

Where a new variable has been created within Q by any means other than copying, the precise mechanics of how it has been created can be determined by right-click on on the variable in the Variables and Questions tab tab and selecting an option beginning with Edit (e.g., Edit Variable and Edit Code Frame), and Q will show you the settings in used when the variable was created (and these can also be edited at this stage).

Tracing dependencies

You can right click on any variable and select Trace Dependencies to understand if and how a variable interacts with other variables in a project. The options in this menu may include:

  • Used By, which identifies other variables that use the selected variable (e.g., are copies of the variable or use it in a JavaScript Variable).
  • Deep Dependencies Used By, shows identifies other variables that use the selected variable, as well as any variables that use these variables, and so on (i.e., all the "descendants" of the variable).
  • Calculated Using, which indicates the variables that are used in the construction of a particular variable
  • Deep Dependencies Calculated Using, which identifies all the ancestors of a variable.

Searching for usage

Find Replace can be used to find any uses of data (e.g., to find all the tables or variables that are created using a specific variable).

Reviewing Rules

If a Rule has been applied to a table, a pink Rules tab (RulesTab.png) will appear at the bottom of the table. This can then be reviewed, modified or deleted.

Viewing the original Variable Label

Pressing ShowSourceLabels.png in the Variables and Questions tab shows the Label of a variable that exists in the raw data file (i.e., prior to being automatically cleaned up by Q when importing data, or, manually changed by a user).

Revert to source

Right-clicking on a question and selecting Revert to source returns the variables to the state they have in the original data file (i.e., undoing Set Question and undoing any changes to the Value Attributes). Some care needs to be taken when using Revert to source with variables created within Q (such variables do not exist in the raw data file so they have no initial state to revert to).

Deleted cases

Where cases have been deleted from the Data tab tab, the cases that have been deleted can be identified by right-clicking on a row in the Data tab and selecting Revert Deleted Rows, which will open a dialog box showing which case have been deleted.

Sorting

If the Data tab has been sorted, this is shown by the order of the row numbers on the left side of the Data tab (the row numbers indicate the position of the rows in the unsorted data file). Select View > Sort to identify how the data has been sorted (and to unsort if required).

Sorting is ignored in any computations within Q. The order of the data as used in any formulas is always the order in the original data file.

Status

The Status column in the Variables and Questions tab tab identifies any variables that have either been broken (e.g., due to a change in the data file structure) as well as any variables where Q has made an educated guess but the user has not checked that this educated guess is correct.

Personal tools
Namespaces

Variants
Actions
Navigation
Categories
Toolbox