Q Cheat Sheet
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Key tips to get you started
ytp ety Start a new project with your data

1. File D> Data Sets P> Add to Project P> From File
2. Select Automatically detect data file structure
3. (Optional) Choose from among Advanced options

In the Outputs tab choose the questions you want to show in the blue and
brown question menus

Modify the table
Country v | SUMMARY v
Duplicate the table Push the Duplicate table button in between the blue and brown

drop down menus to make new tables

Manipulate the table

» Drag-drop categories and columns to move them and merge them
* Right-click to bring up menu of options (dependant on where you click)
o Highlight multiple categories with Shift or Ctrl, and then right-click

What to do when you

Right-click on whatever it is you are trying to change

cannot figure out how to Type into Search

¢ Search features and data

use Q Get help interpreting a table

Help P> Interpret This Table

Read the wiki

Help » Q Wiki (Online Reference Manual)

Do some training modules

Help P> Online Training

Contact support support@gq-researchsoftware.com
. . 1. File > Data Sets P Add to Project » From File
Data files and file Start a new project 2. Select Automatically detect data file structure
management 3. (Optional) Choose from among Advanced options
When you analyze data in Q 1. Double-click on the QPack or File » Open P> Existing Project
| ing two files: Starting using a QPack 2. File » Save
you are always using two Tiles: 3. Read any messages carefully (as you may destroy work)

e Project file (. Q): this Opening a project

File D Open P Existing Project or Recent Projects

contains all the work you Share projects

File P> Share This sends the project and data files (as a Q Pack)

have done in Q. Update the data in a project

File > Data Sets P> Update

o Data file (e.g.,. sav): this X X
. Merge different projects
contains your survey data;

Open two copies of Q and drag and drop tables and variables from one project
to another

Q does not change the Merge data files

Tools P> Merge Data Files

raw data. Stack data

Tools P> Stack SPSS Data File

e A Q Pack (.QPack) is an
archive of your Project Panel data (e.g., occasion-based data)

and your Data

1. Stack the data (if necessary)
2. File > Data Sets P> Add to Project P> From File
3. File > Data Sets P> Edit Relationships

What to do when the data

Contact the person that set up the project (if you did not do it yourself)

looks wrong Check the base

base n = 0; total n = 13; 13 missing; 88% filtered out;

Check n and base n

Statistics — Cells P> n or Base n

Check statistical testing

Show significance: Compare columns =
Edit P Project/Table Options P> Statistical Assumptions

Check that the Question Type setting
makes sense on the Variables and
Questions tab

Either go to the Variables and Questions tab and find the data, or, press '*
to the right of the relevant dropdown menu

Check that the Filter is correct

Eg Filter: Q8. One or more message not recalled

Check that the Weight is appropriate

Eg. Weight: None

Check that the correct rules are applied
and, try and remove the rules

If a Rule has been applied, a pink Rules tab will appear
at the bottom of the table. Control when applied using
the Apply dropdowns

Table |Rules

Hide or unhide variables

On the Variables and Questions tab, press !

Check if empty rows/columns are are
hidden

Check to see if 0 is depressed (this hides empty rows and columns)

Review the Value Attributes

Right-click on a row or column heading and select Values

Review how a variable has been
constructed

1. Go to the Variables and Questions tab
2. Find the variable
3. Right-click: Edit Variable

Contact support

File P Share > Send To Support (encrypted) and indicate which table and
which cells in the table look wrong and why
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Tables and plots

Note that the one of the main
ways of modifying a table is to
change the data in the table,
and when this is done all other
tables using the same data will
also change (see Manipulating
Data)

View additional statistics

Right-click: Statistics — Cells/Right/Below »

Duplicate a table

Push the Duplicate table button in between the blue and brown
drop down menus to make new tables

# Duplicate

Changing the data

Choose the questions you want to show in the blue and brown question menus

Country [+l |suMmARY -

Create plots in Q

Select from Show Data As (top middle of the screen)

Customizing the look and feel of tables

Edit P> Project Options P> Customize and Table Styles

Lock the dropdowns used to select data
on a table

Right-click on table(s) in the Report and select Lock

Create folders

Right-click on a table in the Report and Add group

Create lots of tables

Create P> Tables P> Banner Tables (this also automatically creates banners
and flattens data — see Manipulating Data)

Simultaneously change lots of
tables/plots

Select them all at the same time and then modify as normal (e.g., apply filters,
right-click and Statistics — Cells)

Weights and filters

Weights and filters can be
applied to the entire project or
to selected tables and plots.

Applying filters and weights

In the Outputs tab highlight a table/chart in the report tree and then select from
the Filter or Weight menus. If applied, the filter/weight will be indicated in green.
Filter: Ed|¥| AND Total sample! V ¥ Weight: None v|

Creating a weight

Create P> Variables and Questions P> Variable(s) P Weight

Allowing variables to be selectable as
weights and filters

In the Variables and Questions tab, press F| W

Creating simple filters

Automate P> Browse Online Library P> Filtering P> Create Filters from
Selected Data

Creating filters from a table

Create a table, select the relevant cells and press ?’

Creating complicated filters (eg: filters
involving more than 2 variables, with
OR, NOT and AND statements)

Create P> Variables and Questions P> Variable(s) P> Binary — Complicated
Filter

Visualizations

Convert a table into a plot

1. Select a Table.

Show Di : Table ~
2. Choose an option from the Show Data As menu. ow Data 2=: Table

Interactive and Advanced
Visualizations

1. Create P> Charts P> Visualizations P> ... a

2. Select the new R object in the Report Tree. ™~

3. On the right hand-side in the Object Inspector, link it to a table or variables
Table [[cnccne -

4. Click (hint: you can set Calculate to ‘automatic’ so it automatically
updates if you change the input table/variables)

Viewing raw data

Seeing the raw data for a question

In the Outputs tab Brown dropdown menu: RAW DATA

Seeing raw data for lots of variables in
Excel

1. Select the variables in the Variables and Questions tab
2. Right-click: Export variables to Excel

3. In Excel: VIEW P Freeze Panes P Freeze Top Row
4.In Excel: DATA W Filter

Seeing all the raw data in Q

All the raw data is viewable on the Data tab. You can sort columns, show filters
and re-order the columns (this is done on the Variable and Questions tab)

Exporting

Any chart templates that you
create in Excel, PowerPoint
and Word, are available in the
Format dropdown that
appears when exporting. See
also Viewing raw data.

Export to PDF

File » Export > To PDF

Export to Excel, PowerPoint and Word

] (2] (w]

Automatically update Office exports

Ensure the Office document is open and export the relevant tables/charts again.
If Q can detect them as being already exported to the document, it will give you
the option to Update. See the Q wiki for more details on automatic updating.

Setting default chart types for Office

1. Create Chart Templates using Excel, Word or PowerPoint
2. Edit P User Options P Export Chart Defaults
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Manipulating data

There are lots of tools for
manipulating data. These are
only some of the more
commonly-used basic tools.

Merging

In the Outputs tab: Drag and drop, or, right-click: Merge

Creating NETs

In the Outputs tab: Right-click: Create NET

Sorting/Re-ordering categories

In the Outputs tab:
e Drag and drop
¢ Right-click: Sort By
e See Using Rules on how to automate the sorting of categories on a table

Removing a category and rebasing

In the Outputs tab:
¢ Right-click: Remove (only for mutually exclusive options)
o Filtering: Create a NET and right-click on it: Create filter

Removing a category without rebasing

In the Outputs tab: Right-click: Hide

Switch between % and averages as
main statistics on a table

In the Outputs tab:

1. Right-click on the row or column headers on the table

2. Select the question (its name will appear near the bottom of the menu)
3. Select Restructure data and the appropriate option

Creating a 2" version of a question

In the Outputs tab: Right-click on table row/column heading: Duplicate
Question

Banding numeric variables

1. See Creating a 2nd version of a question above
2. See Switch between % and averages as main statistics on a table above
3. Merge the rows together according to the desired bands — See Merging above

Recoding (changing Value Attributes)

In the Outputs tab: Right-click on table row/column heading, select Values and
change the numbers in the Value column

Create a banner

In the Outputs tab:
1. Create a new table
2. Create P> Banner P> Drag and Drop

Create a new variable

o Variables &Questions tab: Create P> Variables and Questions P
Variable(s) P> JavaScript Formula » Numeric
e Search the Q Wiki for “JavaScript variables” to see examples of basic code

Recoding into a different variable

In the Variables & Questions tab:
1. Right-click: Copy and Paste Variable(s) P Exact copy
2. Modify the variable as per your needs

Standard mathematical functions

In the Variables & Questions tab: Insert Ready-Made Formula(s) >
Mathematical Functions (by Case)

Creating a binary variable

Follow the steps for creating filters in Weights and Filters

Automation in Q

Q brings efficiencies to your
quantitative workflow in many
ways.

For more information, search
the Q wiki and blogs for
‘Automatic’

Using Rules

« Example: Automate P> Online Library P> Sorting and Reordering > Sort
Rows (Automatically Updates when Data Changes)

« If a Rule has been applied, a pink Rules tab will appear at Table |Rules
the bottom of the table

Using QScripts Example: Automate P> Online Library P> Create New Variables P> Create Top
2 Category Variables
Updating your analysis File P> Data Sets P> Update (and replace the datafile)

Automatic Updating of PowerPoint

See: Exporting

Automatic Updating of R

¢ R objects in the Report Tree will turn if out of date (if the source changes)
« If you want the output to update automatically, tick the Automatic box
o If you want to run your calculation manually, leave the box un-ticked

Doing Calculations in R

You can use R to do custom
calculations, and many options
below also use R.

R

Prepare the data

Question Type and Variable Type determine how variables will be used in R
calculations:

o For Numeric variables, choose Number, Number — Multi, or Pick Any

e For Factors, choose Pick One or Pick One — Multi

o For Ordered Factors, also change the Variable Type to Ordered Categorical

Custom Calculations

Create P> R Output

Refer to variables and tables by name to use them in your calculation:
e For variables, check the Name column in the V&Q tab

 For tables, right-click in the Report and select Reference name

Standard R Items in the Create menu marked with [ use R to run the analysis
o If you want the output to update automatically when the data changes, tick the
Automatic Updating Automatic box

o If you want to run your calculation manually, leave the box un-ticked

Advanced Analyses

All are found under the Create
menu.

Many advanced analyses use R
and show the [ symbol.
Some advanced analyses do
not use R.

The advanced analyses that use &

o Link the analysis up to source data (table, variables), as per the steps in in
Interactive and Advanced Visualizations

® In the Object Inspector on the right, you can view and edit the R Code. Go to
Properties > R Code

Further documentation, videos and worked examples are available on the wiki: wiki.q-researchsoftware.com as well as

the Displayr Blog: www.displayr.com/blog
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Question Types

The way that Q presents data is determined by the underlying Question Type of the data. Question types are set automatically when

importing data and can be modified in the Variables and Questions tab.

Question Type

Description

Example

d Text Each observation in the data file What is your name?
contains text.
i: Text — Multi Multiple related fields of text for each Please type in the names of your three favorite soft drinks
observation in the data file. 1. 2. 3.
Pick One A set of mutually exclusive and Are you... O Male O Female
exhaustive categories (i.e., nominal or
ordinal scales).
Pick One — Multi A series of Pick One questions sharing Please rate your satisfaction with the following airlines:
the same scale points. Low Med High
United O O 0
British Airways O O O
Qantas O O O
3 Number A numeric variable (i.e., interval or ratio How many glasses of wine did you drink last night?
scale).
g Number — Multi A series of numeric variables measured Next to the brands below, please indicate how many times you
on the same scale. have purchased them in the past week
Coke ___ Pepsi___ Fanta___
5 Pick Any What is usually referred to in market Which of the following have you bought in the past week?
research as a multiple response or multi
question. Respondents are asked to pick [ Coke 0O Pepsi [ Fanta
all that apply from a list of options.
El Pick Any — Compact Same as Pick Any but stored in a more compact format (see the Q Reference Manual).
Pick Any — Grid A set of binary variables that can be Which of these brands are cool?
thought of as being ordered in two 0O Coke [ Pepsi O Fanta
dimensions (e.g., a Pick Any question Which of these brands are young?
asked in a loop). 0 Coke [ Pepsi [ Fanta
Which of these brands are sexy?
0 Coke 0O Pepsi O Fanta
E ﬁ Number - Grid A question requiring numeric responses,  In the past month, how many economy flights did you take on...

where the variables can be thought of as
being ordered in two dimensions (e.g., a
Number — Multi question asked in a
loop).

Qantas ____ United ___ Delta __
...and how many business class flights did you take on...
Qantas ___ United __ Delta _

Date

A question containing a date.

What is your date of birth?

_/_]19__
1 3 Ranking Multiple numeric variables that Rank the following brands according to how much you like them...
rl
= represent a ranking, where the highest Coke Pepsi Fanta
number is most preferred and ties are
permitted.
X Experiment A Number, Number — Multi, Ranking, Which of these would you buy?

Pick One or Pick One — Multi question,
where the alternatives presented were
varied using an experimental design.

Coke Pepsi Fanta
$2.00 $4.20 $3.20
Can Bottle Flask
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