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Q Cheat Sheet

Key tips to get you started

Start a new project with your data

1. File D Data Sets P> Add to Project > From File
2. Select Automatically detect data file structure
3. (Optional) Choose from among Advanced options

Modify the table

In the Outputs tab choose the questions you want to show in the blue and
brown question menus

Country | |SUMMARY v

Duplicate the table

Push the Duplicate table button in between the blue and brown

Manipulate the table

drop down menus to make new tables
* Drag-drop categories and columns to move them and merge them
* Right-click to bring up menu of options (dependant on where you click)
« Highlight multiple categories with Shift or Ctrl, and then right-click

What to do when you
cannot figure out how to
use Q

Right-click on whatever it is you are trying to change

Type into Search

© Search features and data

Get help interpreting a table

Help P> Interpret This Table

Read the wiki

Help P Q Wiki (Online Reference Manual)

Do some training modules

Help P Online Training

Contact support

support@g-researchsoftware.com

Data files and file
management

When you analyze data in Q
you are always using two files:

® Project file (. Q): this
contains all the work you
have done in Q.

o Data file (e.g., . sav): this
contains your survey data;
Q does not change the
raw data.

e A Q Pack (.QPack) is an
archive of your Project
and your Data

1. File > Data Sets P> Add to Project » From File
Start a new project 2. Select Automatically detect data file structure

3. (Optional) Choose from among Advanced options

1. Double-click on the QPack or File » Open P Existing Project
Starting using a QPack 2. File > Save

3. Read any messages carefully (as you may destroy work)
Opening a project File > Open P> Existing Project or Recent Projects
Share projects File D Share This sends the project and data files (as a Q Pack)

Update the data in a project

File > Data Sets P> Update

Merge different projects

Open two copies of Q and drag and drop tables and variables from one project
to another

Merge data files

Tools P Merge Data Files

Stack data

Tools P> Stack SPSS Data File

Panel data (e.g., occasion-based data)

1. Stack the data (if necessary)
2. File > Data Sets P Add to Project > From File
3. File » Data Sets P> Edit Relationships

What to do when the data
looks wrong

Contact the person that set up the project (if you did not do it yourself)

Check the base

base n = 0; total n = 13; 13 missing; 88% filtered out;

Check n and base n

Statistics — Cells P> n or Base n

Check statistical testing

Show significance: Compare columns =
Edit P> Project/Table Options P> Statistical Assumptions

Check that the Question Type setting
makes sense on the Variables and
Questions tab

Either go to the Variables and Questions tab and find the data, or, press =
to the right of the relevant dropdown menu

Check that the Filter is correct

Eg Filter; Q8. One or more message not recalled

Check that the Weight is appropriate

Eg. Weight: None

Check that the correct rules are applied
and, try and remove the rules

If a Rule has been applied, a pink Rules tab will appear
at the bottom of the table. Control when applied using
the Apply dropdowns

Table |Rules

Hide or unhide variables

On the Variables and Questions tab, press I

Check if empty rows/columns are are
hidden

Check to see if o is depressed (this hides empty rows and columns)

Review the Value Attributes

Right-click on a row or column heading and select Values

Review how a variable has been
constructed

1. Go to the Variables and Questions tab
2. Find the variable
3. Right-click: Edit Variable

Contact support

File > Share P> Send To Support (encrypted) and indicate which table and
which cells in the table look wrong and why
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Tables and plots

Note that the one of the main
ways of modifying a table is to
change the data in the table,
and when this is done all other
tables using the same data will
also change (see Manipulating
Data)

View additional statistics

Right-click: Statistics — Cells/Right/Below »

Duplicate a table

Push the Duplicate table button in between the blue and brown
drop down menus to make new tables

5 Duplicate

Changing the data

Choose the questions you want to show in the blue and brown question menus

Country v SUMMARY v

Create plots in Q

Select from Show Data As (top middle of the screen)

Customizing the look and feel of tables

Edit D> Project Options P> Customize and Table Styles

Lock the dropdowns used to select data
on a table

Right-click on table(s) in the Report and select Lock

Create folders

Right-click on a table in the Report and Add group

Create lots of tables

Create P> Tables P> Banner Tables (this also automatically creates banners
and flattens data — see Manipulating Data)

Simultaneously change lots of
tables/plots

Select them all at the same time and then modify as normal (e.g., apply filters,
right-click and Statistics — Cells)

Weights and filters

Weights and filters can be
applied to the entire project or
to selected tables and plots.

Applying filters and weights

In the Outputs tab highlight a table/chart in the report tree and then select from
the Filter or Weight menus. If applied, the filter/weight will be indicated in green.

Filter:

B v AND Totalsamplelv| ™ Weight None M

Creating a weight

Create P> Variables and Questions P> Variable(s) > Weight

Allowing variables to be selectable as
weights and filters

In the Variables and Questions tab, press F| W

Creating simple filters

Automate P> Browse Online Library P> Filtering B> Create Filters from
Selected Data

Creating filters from a table

Create a table, select the relevant cells and press

Creating complicated filters (eg: filters
involving more than 2 variables, with
OR, NOT and AND statements)

Create P> Variables and Questions P> Variable(s) P> Binary — Complicated
Filter

Visualizations

Convert a table into a plot

1. Select a Table.

Show Data as: Table =
2. Choose an option from the Show Data As menu. owletaas Tehe

Interactive and Advanced
Visualizations

1. Create P> Charts P> Visualizations P> ... : P2

2. Select the new R object in the Report Tree.

3. On the right hand-side in the Object Inspector, link it to a table or variables
Table [cick pere -]

4. CIick (hint: you can set Calculate to ‘automatic’ so it automatically
updates if you change the input table/variables)

Viewing raw data

Seeing the raw data for a question

In the Outputs tab Brown dropdown menu: RAW DATA

Seeing raw data for lots of variables in
Excel

1. Select the variables in the Variables and Questions tab
2. Right-click: Export variables to Excel

3.In Excel: VIEW P Freeze Panes P Freeze Top Row
4.In Excel: DATA W Filter

Seeing all the raw data in Q

All the raw data is viewable on the Data tab. You can sort columns, show filters
and re-order the columns (this is done on the Variable and Questions tab)

Exporting

Any chart templates that you
create in Excel, PowerPoint
and Word, are available in the
Format dropdown that
appears when exporting. See
also Viewing raw data.

Export to PDF

File » Export » To PDF

Export to Excel, PowerPoint and Word

& @ @

Automatically update Office exports

Ensure the Office document is open and export the relevant tables/charts again.
If Q can detect them as being already exported to the document, it will give you
the option to Update. See the Q wiki for more details on automatic updating.

Setting default chart types for Office

1. Create Chart Templates using Excel, Word or PowerPoint
2. Edit > User Options P Export Chart Defaults
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Manipulating data

There are lots of tools for
manipulating data. These are
only some of the more
commonly-used basic tools.

Merging

In the Outputs tab: Drag and drop, or, right-click: Merge

Creating NETs

In the Outputs tab: Right-click: Create NET

Sorting/Re-ordering categories

In the Outputs tab:

e Drag and drop

* Right-click: Sort By

e See Using Rules on how to automate the sorting of categories on a table

Removing a category and rebasing

In the Outputs tab:
* Right-click: Remove (only for mutually exclusive options)
o Filtering: Create a NET and right-click on it: Create filter

Removing a category without rebasing

In the Outputs tab: Right-click: Hide

Switch between % and averages as
main statistics on a table

In the Outputs tab:

1. Right-click on the row or column headers on the table

2. Select the question (its name will appear near the bottom of the menu)
3. Select Restructure data and the appropriate option

Creating a 2" version of a question

In the Outputs tab: Right-click on table row/column heading: Duplicate
Question

Banding numeric variables

1. See Creating a 2nd version of a question above
2. See Switch between % and averages as main statistics on a table above
3. Merge the rows together according to the desired bands — See Merging above

Recoding (changing Value Attributes)

In the Outputs tab: Right-click on table row/column heading, select Values and
change the numbers in the Value column

Create a banner

In the Outputs tab:
1. Create a new table
2. Create P> Banner P> Drag and Drop

Create a new variable

» Variables &Questions tab: Create P> Variables and Questions P
Variable(s) P> JavaScript Formula P Numeric
o Search the Q Wiki for “JavaScript variables” to see examples of basic code

Recoding into a different variable

In the Variables & Questions tab:
1. Right-click: Copy and Paste Variable(s) » Exact copy
2. Modify the variable as per your needs

Standard mathematical functions

In the Variables & Questions tab: Insert Ready-Made Formula(s) »
Mathematical Functions (by Case)

Creating a binary variable

Follow the steps for creating filters in Weights and Filters

Automation in Q

Q brings efficiencies to your
quantitative workflow in many
ways.

For more information, search
the Q wiki and blogs for
‘Automatic’

Using Rules

o Example: Automate P> Online Library P> Sorting and Reordering P Sort
Rows (Automatically Updates when Data Changes)
Table |Rules

Using QScripts

« If a Rule has been applied, a pink Rules tab will appear at
the bottom of the table

Example: Automate P> Online Library P Create New Variables P> Create Top

2 Category Variables

Updating your analysis

File P> Data Sets P> Update (and replace the datafile)

Automatic Updating of PowerPoint

See: Exporting

* R objects in the Report Tree will turn if out of date (if the source changes)

Automatic Updating of R « If you want the output to update automatically, tick the Automatic box
« If you want to run your calculation manually, leave the box un-ticked
Doing Calculations in R Questlgn Type and Variable Type determine how variables will be used in R
calculations:
You can use R to do custom Prepare the data o For Numeric variables, choose Number, Number — Multi, or Pick Any

calculations, and many options
below also use R.

R

» For Factors, choose Pick One or Pick One — Multi
* For Ordered Factors, also change the Variable Type to Ordered Categorical

Custom Calculations

Create P> R Output

Refer to variables and tables by name to use them in your calculation:

e For variables, check the Name column in the Variables & Questions tab
« For tables, right-click in the Report and select Reference name

Standard R Items in the Create menu marked with [ use R to run the analysis
« If you want the output to update automatically when the data changes, tick the
Automatic Updating Automatic box

« If you want to run your calculation manually, leave the box un-ticked

Advanced Analyses

All are found under the Create
menu.

Many advanced analyses use R
and show the [ symbol.
Some advanced analyses do
not use R.

The advanced analyses that use [

« Link the analysis up to source data (table, variables), as per the steps in in
Interactive and Advanced Visualizations

® In the Object Inspector on the right, you can view and edit the R Code. Go to
Properties > R Code

Further documentation, videos and worked examples are available on the wiki: wiki.g-researchsoftware.com as well as

the Displayr Blog: www.displayr.com/blog
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Question Types

ca
The way that Q presents data is determined by the underlying Question Type of the data. Question types are set automatically when
importing data and can be modified in the Variables and Questions tab.

Question Type Description

Example

d  Text Each observation in the data file

contains text.

What is your name?

@ Text — Multi

a Multiple related fields of text for

each observation in the data file.

Please type in the names of your three favorite soft drinks
1. 2. 3.

Pick One A set of mutually exclusive and
exhaustive categories (i.e., nominal

or ordinal scales).

Are you... O Male O Female

Pick One — Multi A series of Pick One questions

Please rate your satisfaction with the following airlines:

sharing the same scale points. Low Med High
United O [} [}
British Airways O O O
Qantas O O [}
2 Number A numeric variable (i.e., interval or How many glasses of wine did you drink last night?
ratio scale).
E Number — Multi A series of numeric variables Next to the brands below, please indicate how many times you
measured on the same scale. have purchased them in the past week
Coke ___ Pepsi___ Fanta ___
E Pick Any What is usually referred to in market ~ Which of the following have you bought in the past week?

research as a multiple response or
multi question. Respondents are
asked to pick all that apply from a list
of options.

0O Coke [ Pepsi O Fanta

= Pick Any — Compac

Same as Pick Any but stored in a more compact format (see the Q Reference Manual).

& Pick Any - Grid A set of binary variables that can be Which of these brands are cool?
i thought of as being ordered in two 0O Coke [ Pepsi O Fanta
dimensions (e.g., a Pick Any question  Which of these brands are young?
asked in a loop). 0 Coke [J Pepsi [ Fanta
Which of these brands are sexy?
0 Coke [ Pepsi [ Fanta
E j Number — Grid A question requiring numeric In the past month, how many economy flights did you take on...

responses, where the variables can
be thought of as being ordered in
two dimensions (e.g., a Number —
Multi question asked in a loop).

Qantas ____ United ___ Delta ___
...and how many business class flights did you take on...
Qantas ____ United ___ Delta ___

A question containing a date.

Date

What is your date of birth?
__/__J19____

1 _’5- Ranking Multiple numeric variables that
= represent a ranking, where the
highest number is most preferred

and ties are permitted.

Rank the following brands according to how much you like them...

Coke Pepsi Fanta

X Experiment A Number, Number — Multi, Ranking,
Pick One or Pick One — Multi
question, where the alternatives
presented were varied using an

experimental design.

Which of these would you buy?

Coke Pepsi Fanta
$2.00 $4.20 $3.20
Can Bottle Flask
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